[Piglit] [PATCHv2 00/10] add infrastructure for GLES1 tests
Chia-I Wu
olvaffe at gmail.com
Sun Sep 4 19:44:51 PDT 2011
Changes since v1 are
- change how switch cases are guarded in piglit_get_gl_error_name
- rename piglit-util-gles2.c to piglit-util-gles.c, and let GLES1 and
GLES2 share it
- hide enum naming differences in gl_wrap.h
(e.g. define GL_TEXTURE_CUBE_MAP_POSITIVE_X to
GL_TEXTURE_CUBE_MAP_POSITIVE_X_OES for GLES1)
- call piglit_report_result(PIGLIT_SKIP) when piglit_require_GLSL or
other shader related helpers are called in piglitutil_gles1
More information about the Piglit
mailing list