[Piglit] [PATCH] texwrap: do no short circuit remaining tests if one fails

Emil Velikov emil.l.velikov at gmail.com
Sun Nov 22 03:43:07 PST 2015


On 11 November 2015 at 18:07, Emil Velikov <emil.l.velikov at gmail.com> wrote:
> From: Emil Velikov <emil.velikov at collabora.com>
>
> Noticed as some of these have been intermittently failing on llvmpipe,
> resulting in a few "not run" test across mesa release checks.
>
> Signed-off-by: Emil Velikov <emil.velikov at collabora.com>
> ---
>
> XXX:
> At some point we'd want to do a tree-wide:
>  - s/GLboolean pass/bool pass/
>  - s/pass = pass && foo/pass &= foo/
>  - s/pass = foo && pass/pass &= foo/
>
> We might want to convert the test to use the piglit_probe_pixels over
> it's custom ones.
>
> -Emil
>
>  tests/texturing/texwrap.c | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/tests/texturing/texwrap.c b/tests/texturing/texwrap.c
> index fbe9068..60ffa73 100644
> --- a/tests/texturing/texwrap.c
> +++ b/tests/texturing/texwrap.c
> @@ -1134,7 +1134,7 @@ static GLboolean test_format_npot(const struct format_desc *format, GLboolean np
>                  * It has to be enabled on the command line.
>                  */
>                 if (!texture_swizzle && !npot && !test_border_color && has_texture_swizzle) {
> -                       pass = pass && test_format_npot_swizzle(format, npot, 1);
> +                       pass = test_format_npot_swizzle(format, npot, 1) && pass;
>                 }
>         }
>         return pass;
> @@ -1149,7 +1149,7 @@ static GLboolean test_format(const struct format_desc *format)
>         } else {
>                 pass = test_format_npot(format, 0);
>                 if (has_npot && !test_border_color) {
> -                       pass = pass && test_format_npot(format, 1);
> +                       pass = test_format_npot(format, 1) && pass;
>                 }
>         }
>         return pass;
> @@ -1163,7 +1163,7 @@ enum piglit_result piglit_display()
>                 pass = test_format(init_format ? init_format : &test->format[0]);
>         } else {
>                 if (init_format) {
> -                       pass = pass && test_format(init_format);
> +                       pass = test_format(init_format) && pass;
>                 } else {
>                         int i;
>                         for (i = 0; i < test->num_formats; i++) {
> --
Any takers on this trivial patch ? I guess we can bikeshed the "pass =
foo && pass" vs "pass &= foo" at a later stage.

-Emil


More information about the Piglit mailing list