[Piglit] [PATCH 00/14] framework: Cleanup the core module

Dylan Baker dylan at pnwbakers.com
Fri May 6 20:07:10 UTC 2016


I'm trying to clear out my piglit repo of any branches that look like
they might be slightly useful, as I start to migrate my main focus away
from improving the framework and towards maintenance with a focus
elsewhere.

This little series fixes up some of the consistency issues with some of
the oldest code in the codebase. Ultimately this may be split up more
than is necessary and I can squash them if people prefer.

It also adds documentation to modules and functions that lacked it
before.

Note that most of the code additions are unittests rather than changes
in the framework itself.

Dylan Baker (14):
  unittests/core_tests.py: add tests for core.checkDir
  core.py: use 'in list' instead of a == b or a == c...
  core.py: remove flag from checkDir, use exception block
  core.py: only call makedirs if the directory doesn't exist
  core.py: use PiglitFatalError instead of sys.exit
  framework: core.checkDir raises PiglitException
  framework: rename core.checkDir to core.check_dir
  core.py: make second argument to check_dir a keyword argument
  core.py: add docstring to check_dir
  framework/core: extend check_dir to take a handler callable
  framework/core.py: Make copyright header match others in the framework
  framework/core.py: add module docstring
  framework/summary/html_.py: use core.check_dir
  unittests/core_tests.py: Add tests that only apply to python3

 framework/core.py             | 91 +++++++++++++++++++++++++++----------------
 framework/programs/run.py     | 27 +++++++------
 framework/programs/summary.py |  8 +++-
 framework/summary/html_.py    | 25 +++++-------
 unittests/core_tests.py       | 74 +++++++++++++++++++++++++++++++++++
 unittests/utils.py            | 25 ++++++++++++
 6 files changed, 188 insertions(+), 62 deletions(-)

-- 
2.8.2



More information about the Piglit mailing list