[Piglit] [PATCH 2/8] arb_tessellation_shader/execution/trivial: new trivial tess test

Ilia Mirkin imirkin at alum.mit.edu
Tue Apr 11 14:39:09 UTC 2017

On Tue, Apr 11, 2017 at 5:08 AM, Marek Olšák <maraeo at gmail.com> wrote:
> On Apr 10, 2017 11:11 PM, "Ilia Mirkin" <imirkin at alum.mit.edu> wrote:
> Is this substantially different than patch-single-vert.shader_test or
> patch-pair-verts.shader_test? Is the 4 vertices that's important to
> your test? If so, patch-four-verts.shader_test seems like a better
> name.
> That's a really bad name, because it doesn't tell me that the test is
> trivial. See, I didn't even bother checking what
> patch-pair-verts.shader_test does. Bad name.

So are sanity, nop, trivial, sanity2... All the tests are trivial
except quads.shader_test as I recall. Perhaps rename them all with a
"trivial-" prefix? Or make a dir?

More information about the Piglit mailing list