[Piglit] [PATCH 1/4] glsl-1.10: rename function chain test and better test the inout param

Timothy Arceri tarceri at itsqueeze.com
Mon Apr 9 09:44:40 UTC 2018


From: Timothy Arceri <t_arceri at yahoo.com.au>

The following patch will add a number of variants of this test so
we want to give it a more descriptive name.
---
 .../function-calls/glsl-function-chain16-inout.shader_test}   | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
 rename tests/{shaders/glsl-function-chain16.shader_test => spec/glsl-1.10/execution/function-calls/glsl-function-chain16-inout.shader_test} (96%)

diff --git a/tests/shaders/glsl-function-chain16.shader_test b/tests/spec/glsl-1.10/execution/function-calls/glsl-function-chain16-inout.shader_test
similarity index 96%
rename from tests/shaders/glsl-function-chain16.shader_test
rename to tests/spec/glsl-1.10/execution/function-calls/glsl-function-chain16-inout.shader_test
index 25d5946ac..74b232956 100644
--- a/tests/shaders/glsl-function-chain16.shader_test
+++ b/tests/spec/glsl-1.10/execution/function-calls/glsl-function-chain16-inout.shader_test
@@ -16,7 +16,7 @@ void f10(inout float f);
 void f14(inout float f);
 void main()
 {
-	float g;
+	float g = 0.1;
 	f01(g);
 	gl_FragColor = vec4(g, 0, 0, 1.0);
 }
@@ -52,7 +52,7 @@ void f13(inout float f);
 void f04(inout float f) {f05(f);}
 void f08(inout float f) {f09(f);}
 void f12(inout float f) {f13(f);}
-void f16(inout float f) {f=0.2;}
+void f16(inout float f) {f+=0.1;}
 
 
 [test]
-- 
2.17.0



More information about the Piglit mailing list