[Piglit] [PATCH] shaders: add a glslparsertest for bug 98699

Timothy Arceri tarceri at itsqueeze.com
Mon Aug 13 03:15:21 UTC 2018


On 11/08/18 02:32, Dylan Baker wrote:
> I thought we'd stopped adding tests with "bugXXXXX" in the name and tried to
> give the test a descriptive name and we were trying not to add more
> tests to tests/shaders, but put them in tests/spec/. So maybe rename
> it to something like:
> tests/spec/glsl-1.10/compiler/post-increment-in-array-size.shader_test

Yes I agree with Dylan on all points. With the move/rename this is:

Reviewed-by: Timothy Arceri <tarceri at itsqueeze.com>

> 
> Or whatever you think is better (I'm just reading the bug and trying to come up
> with something).
> 
> Otherwise this test looks good, so with the rename:
> Reviewed-by: Dylan Baker <dylan at pnwbakers.com>
> 
> Quoting Tapani Pälli (2018-08-09 23:12:44)
>> Signed-off-by: Tapani Pälli <tapani.palli at intel.com>
>> Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=98699
>> ---
>>   tests/shaders/glsl-compiler-bug98699.vert | 9 +++++++++
>>   1 file changed, 9 insertions(+)
>>   create mode 100644 tests/shaders/glsl-compiler-bug98699.vert
>>
>> diff --git a/tests/shaders/glsl-compiler-bug98699.vert b/tests/shaders/glsl-compiler-bug98699.vert
>> new file mode 100644
>> index 000000000..9bd219cf0
>> --- /dev/null
>> +++ b/tests/shaders/glsl-compiler-bug98699.vert
>> @@ -0,0 +1,9 @@
>> +// [config]
>> +// expect_result: fail
>> +// glsl_version: 1.10
>> +// [end config]
>> +
>> +void main()
>> +{
>> +        float[a+++4 ? 1:1] f;
>> +}
>> -- 
>> 2.14.4
>>
>> _______________________________________________
>> Piglit mailing list
>> Piglit at lists.freedesktop.org
>> https://lists.freedesktop.org/mailman/listinfo/piglit
>>
>>
>> _______________________________________________
>> Piglit mailing list
>> Piglit at lists.freedesktop.org
>> https://lists.freedesktop.org/mailman/listinfo/piglit


More information about the Piglit mailing list