[Pixman] [PATCH 0/7] Clean up delegation logic

Søren Sandmann sandmann at cs.au.dk
Sat Sep 15 16:54:27 PDT 2012


Hi,

The following patches move all the delegation logic into
pixman-implementation.c and then, since the chain of implementations
no longer has anything to do with the delegation design pattern,
rename "delegate" to "fallback".

It's a net win of 227 lines of code, and makes pixman-implementation.c
look a lot nicer because all the trivial "delegate_blah()" functions
go away.

There are some changes to the NEON and DSPr2 backends that I haven't
tried to compile. If there are any problems there, please let me know.

Thanks,
Soren

 pixman-arm-neon.c       |   89 +++------------
 pixman-fast-path.c      |    6 -
 pixman-general.c        |   46 +-------
 pixman-glyph.c          |    4 
 pixman-implementation.c |  276 ++++++++++++++++++++++++++++++++----------------
 pixman-mips-dspr2.c     |   89 +++------------
 pixman-mmx.c            |  119 ++++++--------------
 pixman-noop.c           |   14 +-
 pixman-private.h        |   36 +++---
 pixman-sse2.c           |  146 ++++++++-----------------
 pixman-utils.c          |  112 -------------------
 pixman.c                |    2 
 12 files changed, 356 insertions(+), 583 deletions(-)



More information about the Pixman mailing list