[Pixman] pixman-0.32.6, Solaris 11.1 amd64

Noel Hunt noel.hunt at gmail.com
Thu Jul 24 22:13:38 PDT 2014

On Fri, Jul 25, 2014 at 9:13 AM, Siarhei Siamashka <
siarhei.siamashka at gmail.com> wrote:

> A lot has changed since the pixman version 0.24.4
> Can you provide more information about your compiler and maybe the
> configure logs?

Thanks for your response. I have attached the config.log,
but I have had to hand-edit Makefiles to get the mmx and
ssse3 stuff compiled in (which made no difference to the
test) since configure doesn't know how to do this on Solaris.

The compiler is the Solaris Studio

% cc -V
cc: Sun C 5.13 SunOS_i386 Beta2 2014/06/17

and it has a -xarch=ssse3 option for the SSE3 extension.
Configure knows about -xarch=ssse2 only.
Also, the include file for the intrinsics on Solaris is not
known to configure (#include <sunmedia_intrinsics.h>
which comes with the compiler distribution).

I have built this as part of building the xorg-server-1.15.2.
Such a recent version of pixman wasn't necessary, any
version from 0.27.1 up (but this latter doesn't exist in
your repository). I got the server built and after my session
started I was running `firefox' which comes with Solaris 11.1
and it was distinctly broken. The window was more or less
blank. It was only when I closed the session (run from
`startx' that I noticed these pixman errors, and it was then
that I tried the clip-test program with the same result.

And my reason for doing all this is because the installed
Xorg, X.Org X Server 1.12.2 with its intel driver 2.18.0
doesn't work with my monitor/graphics card, so I was
hoping to build a recent version to have access to
debugging code (I am running with the vesa driver).

So, that's why I am building pixman. I did this morning
build a rather earlier version 0.28.0, but it has the same

Noel Hunt
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/pixman/attachments/20140725/dddcd612/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: config.log
Type: application/octet-stream
Size: 56849 bytes
Desc: not available
URL: <http://lists.freedesktop.org/archives/pixman/attachments/20140725/dddcd612/attachment-0001.obj>

More information about the Pixman mailing list