test failure in pkg-config 0.21

Paul Novak pdnovak at comcast.net
Mon Jan 15 12:33:56 PST 2007

I'm trying to build pkg-config 0.21 on my first Linux From Scratch system.

    ./configure --prefix=/usr && make && make check

I got this (one) test failure:

    ../pkg-config --cflags requires-test :
    '-I/requires-test/include -I/private-dep/include -I/public-dep/include' != '-I/requires-test/include -I/public-dep/include'
    FAIL: check-requires-private

pkg-config returns a result with "-I/private-dep/include", but the expected
result in the test script does not.

I guessed this was something wrong with my setup on LFS, so I tried
same thing on my old reliable/stable Slackware 10.2 machine and I got
the identical failure.

I went back (on Slackware) and tried pkg-config 0.20, and it built and 
tested cleanly, including the check-requires-private test.  
In 0.20, pkg-config does not return "-I/private-dep/include".

Should pkg-config be returning "-I/private-dep/include" in 0.21?
If yes, should the test result be patched?  If no, should I use 0.20?

pdnovak at comcast.net

More information about the pkg-config mailing list