[Pm-utils] i810 driver, on resume, sometimes either locks or blank screen

John H. mistamaila at gmail.com
Wed Nov 8 11:16:57 PST 2006

ah shoot, it worked several times, even several times today, but just
a bit ago, after i had suspended for several minutes and tried to
resume, i got no video on resume:(

the keys seemed to work, though.  it seems to have helped w/lock ups
when i commented out this line

#       /usr/sbin/vbetool vbestate restore < /var/run/vbestate
in resume_video function?

On 11/7/06, Peter Jones <pjones at redhat.com> wrote:
> On Fri, 2006-11-03 at 15:45 -0500, John H. wrote:
> > It's almost as if, if it's for an extended period of time, there's a
> > far greater chance of it not resuming.  If I do it for a few minutes,
> > it generally resumes fine every time.
> >
> > Any ideas?
> Hrm.  This sounds like it _could_ be similar to a bug we're seeing on
> thinkpads, where acpi events aren't delivered for a few minutes at a
> time.  I don't really have a solution for it, unfortunately.
> How far is it getting on resume?  Is it coming back at all?  Do drives
> spin up, or LEDs come on?  Does it get that far, or does it just not do
> anything?
> --
>   Peter

More information about the Pm-utils mailing list