[Pm-utils] [patch review] Another try at sleep method modularization
Victor Lowther
victor.lowther at gmail.com
Thu Feb 7 20:33:45 PST 2008
This is another try at sleep method modularization. It attempts to address
the issues with my previous attempt along these lines. Specifically:
* Instead of calling little scripts named with a specific naming scheme,
this patch sources appropriately-named libraries of functions.
* No more nasty passing of a function with a parameter in quotes to run_hooks.
Since this patch series is mainly for discussion, it does not include the
documentation updates the previous one did, nor does it include any special
handling of per-sleep_method configuration (which tuxonice will need).
This patch series shuld apply gleanly on top of current fd.o git head, and
can be pulled from git://fnordovax.org/pm-utils branch
vlowther-even-simpler-simpler-sleep-modules
configure.in | 1 +
pm/Makefile.am | 5 +++-
pm/functions.in | 23 ++++++++-----------
pm/module.d/Makefile.am | 10 ++++++++
pm/module.d/kernel | 28 ++++++++++++++++++++++++
pm/module.d/tuxonice | 32 ++++++++++++++++++++++++++++
src/pm-action.in | 36 ++++++-------------------------
src/pm-is-supported | 53 -----------------------------------------------
src/pm-is-supported.in | 36 +++++++++++++++++++++++++++++++
9 files changed, 128 insertions(+), 96 deletions(-)
More information about the Pm-utils
mailing list