[Pm-utils] Black unresponsive screen after hibernate/thaw presumably due to NVIDIA driver

Michel DEVEL michel.devel at univ-fcomte.fr
Sun Oct 20 18:23:40 PDT 2013

Dear pm-utils users and developers,

This is my first mail on this list so I present myself a bit:
I am a long time user of opensuse at work and at home, but I am only a 
user and certainly not a system expert, so that even after reading some 
of the documentation for the opensuse implementation of pm-utils, I 
still have problems to be able to sort out by myself a problem with 

I have had a problem with hibernate/resume on my computer since at least 
the default pm-utils that was integrated in opensuse 11.4 until now 
(12.3)! (In fact I do not remember that it ever worked for me). The 
problem is that I usually have plenty of softs and at least one virtual 
machine opened at the same time (I have 24 GB of RAM) so that I almost 
never shutdown and reboot my PC and have very rarely the occasion and 
time to experiment with hibernate.
Hence, if you solve the following problem, you will also make a good 
action for the planet since I will be able to use hibernation at the end 
of every working day!

The current version of pm-utils on my PC is   1.4.1-26.17.1

The hibernate and resume just go on all right (success at the end of 
pm-suspend.log and 100% of data image loaded) but I get a black screen 
afterward (and neither Ctrl-Alt-F1 to F12 works nor Ctrl-Alt-Esc or 

By checking Xorg.0.log against Xorg.0.log.old, I see that at the end 
after the EDID checks I have
[ 4863.515] (II) Open ACPI successful (/var/run/acpid.socket)
[ 4863.592] (WW) NVIDIA(GPU-0): Failed to enter interactive mode.
[ 4863.592] (EE) NVIDIA(GPU-0): Failed to determine display capabilities
[ 4863.592] (EE) *** Aborting ***
[ 4863.592]
Fatal server error:
[ 4863.592] EnterVT failed for screen 0
[ 4863.592]
[ 4863.592] (EE)
Please consult the The X.Org Foundation support
at xorg <http://wiki.x.org>
for help.
[ 4863.592] (EE) Please also check the log file at "/var/log/Xorg.0.log" 
for additional information.
[ 4863.592] (EE)
[ 4863.594] (II) evdev: Logitech HID compliant keyboard: Close
[ 4863.594] (II) UnloadModule: "evdev"
[ 4863.594] (II) evdev: Logitech HID compliant keyboard: Close
[ 4863.595] (II) UnloadModule: "evdev"
[ 4863.596] (II) evdev: Microsoft Corporation Microsoft ® Laser Mouse 
6000: Close
[ 4863.596] (II) UnloadModule: "evdev"
[ 4863.596] (II) evdev: STV06xx: Close
[ 4863.596] (II) UnloadModule: "evdev"
[ 4863.597] (II) evdev: Power Button: Close
[ 4863.597] (II) UnloadModule: "evdev"
[ 4863.597] (II) evdev: Power Button: Close
[ 4863.597] (II) UnloadModule: "evdev"

I have tried to google "(EE) NVIDIA(GPU-0): Failed to determine display 
capabilities" but the only reference are for my former posts on the 
opensuse forums

My graphics card is a GTX260 and I use x11-video-nvidiaG03, 
nvidia-gfx03-kmp-desktop and nvidia-computeG03 from 
obs://build.suse.de/home:sndirsch:drivers though I do not have this repo 
in my list (I have ftp://download.nvidia.com/opensuse/12.3/) ...

I have tried to create a script named first 99znvidia the 99nvidia with

. $PM_UTILS_LIBDIR/functions

case "$1" in
modunload nvidia
modreload nvidia

exit 0

The script was executed during hibernate and thaw with success, but my 
screen stayed black and unresponsive after the image was loaded into 
memory and pm_suspend.log contains only success.

Any help will be appreciated.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/pm-utils/attachments/20131021/8c7b8b74/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: image/png
Size: 1568 bytes
Desc: not available
URL: <http://lists.freedesktop.org/archives/pm-utils/attachments/20131021/8c7b8b74/attachment.png>

More information about the Pm-utils mailing list