<html>
<head>
<base href="https://bugs.freedesktop.org/">
</head>
<body>
<p>
<div>
<b><a class="bz_bug_link
bz_status_NEW "
title="NEW - [patch] add support for subpixel rendering support for cairo backend"
href="https://bugs.freedesktop.org/show_bug.cgi?id=95485#c1">Comment # 1</a>
on <a class="bz_bug_link
bz_status_NEW "
title="NEW - [patch] add support for subpixel rendering support for cairo backend"
href="https://bugs.freedesktop.org/show_bug.cgi?id=95485">bug 95485</a>
from <span class="vcard"><a class="email" href="mailto:ajohnson@redneon.com" title="Adrian Johnson <ajohnson@redneon.com>"> <span class="fn">Adrian Johnson</span></a>
</span></b>
<pre>Comment on <span class=""><a href="attachment.cgi?id=123900" name="attach_123900" title="proposed patch">attachment 123900</a> <a href="attachment.cgi?id=123900&action=edit" title="proposed patch">[details]</a></span> <a href='page.cgi?id=splinter.html&bug=95485&attachment=123900'>[review]</a>
proposed patch
Review of <span class=""><a href="attachment.cgi?id=123900" name="attach_123900" title="proposed patch">attachment 123900</a> <a href="attachment.cgi?id=123900&action=edit" title="proposed patch">[details]</a></span> <a href='page.cgi?id=splinter.html&bug=95485&attachment=123900'>[review]</a>:
-----------------------------------------------------------------
::: glib/poppler-page.cc
@@ +2426,5 @@
<span class="quote">> }
> +
> +gboolean
> +poppler_page_support_subpixel_rendering (PopplerPage *page)
> +{</span >
This is not a good function name. PDF pages do not "support" subpixel
rendering. The limitation is in cairo not supporting component alpha.
It would be better to call it something like poppler_page_requires_blend_modes.
Maybe this could be generalized to a method of checking what PDF functionality
the page requires. I'm not sure what the glib way of doing this is.
::: poppler/CairoOutputDev.cc
@@ +1422,5 @@
<span class="quote">>
> + fontType = state->getFont()->getType();
> + // Do not enable subpixel rendering for type3 font
> + // For some reason it does not work
> + if (fontType == fontType3) {</span >
This should be in a separate patch. Also needs an explanation why it is needed
and a test case.</pre>
</div>
</p>
<hr>
<span>You are receiving this mail because:</span>
<ul>
<li>You are the assignee for the bug.</li>
</ul>
</body>
</html>