[poppler] Postscript got from pdftops has some glyphs missing

shyama.venugopal at emc.com shyama.venugopal at emc.com
Sun Jul 22 23:00:38 PDT 2012

Hi Jim,

Thank you for the response. I did try passing the pdf directly to ghostscript which resulted in a lot of other non conformance errors in the preflight like annotations inside trim box. 

I did tried -level3 and -level3sep but no luck. When I run pdffonts on the original pdf I do all the fonts marked as embedded='yes'.

Is there any other configuration I can use?

Thank you,

-----Original Message-----
From: James Cloos [mailto:cloos at jhcloos.com] 
Sent: Friday, July 20, 2012 9:48 PM
To: Venugopal, Shyama
Cc: poppler at lists.freedesktop.org
Subject: Re: [poppler] Postscript got from pdftops has some glyphs missing

>>>>> "s" == shyama  <shyama.venugopal at emc.com> writes:

s> I am then passing the output ps to ghostscript to get a PDF/X-3
s>  conformant file.

Ghostscript can take pdf directly; have you tried omitting the conversion
to postscript?

If that doesn't work, I'd use -level3 or -level3sep rather than -level2.

Does the original pdf have all of its fonts embedded?  (Run poppler's pdffonts
on the pdf; you want every row under the 'emb' column to be yes.)

James Cloos <cloos at jhcloos.com>         OpenPGP: 1024D/ED7DAEA6

More information about the poppler mailing list