[pulseaudio-discuss] Expected level of ALSA/OSS compatibility

Pierre Ossman ossman at cendio.se
Tue Apr 17 07:29:41 PDT 2007

Neilen Marais wrote:
> So, I'd like to know what is the ultimate level of ALSA/OSS compatibility
> that can be expected? Are there certain things that just can't be emulated
> by a non-kernel deamon? I've googled a bit, but can't seem to find any
> definite answers. And if I find apps that don't want to work with the
> ALSA/OSS emulation, should I report them all as bugs?

Generally, the emulation is rather complete. The big thing that pulse
cannot emulate is mmap because it gives latency guarantees that we
cannot satisfy.

Generally, when stuff doesn't work the problem has been that the program
abuses the OSS/ALSA API in a way that happens to work with real
hardware. Feel free to file bugs though and we'll look at them as time

I'd like you to test using the latest HEAD of the software before filing
bugs though. It eats valuable time to chase a problem that's already
been solved.

> XMMS: Ubuntu doesn't ship the pulseaudio plugin, so out of lazyness I
> tried talking to PA through both ALSA and ESD output plugins, neither of
> which worked. A connection seems to get created with pulseaudio (I can see
> "ALSA plug-in [xmms]" in paman), but xmms claims there is a problem with
> the audio device.  I compiled and installed the PulseAdio xmms plugin
> myself, which works, so I'm happy with XMMS support now.

Haven't tested this so I do not know the problem here. Have you
unchecked "mmap" in xmms?

> Audacity: Can't get it to work; it simply doesn't list the PA ALSA
> devices, and gives me an error if I try to use padsp (see
> https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/107207 )

Audacity with PortAudio 18 and padsp works rather well (several of our
customers use it). Haven't tried it with ALSA.

padsp and PortAudio 19 doesn't work because of a bug in PortAudio. It
makes incorrect assumptions about how write() works. When I have the
time I'll dig more and file a bug with PortAudio.

> mplayer: Don't have the PA patch applied yet. PA ALSA emulation doesn't
> work, padsp strangely does work quite well.

mplayer (incorrectly) looks for _hardware_ devices, and then proceeds to
not use them (it uses normal ALSA devices just like most apps). Feel
free to nag them. :)

> totem-xine: Again the ubuntu version doesn't seem to include a PA plugin,
> but the PA ALSA emulation seems to work a treat.

Haven't tested xine unfortunately.

Pierre Ossman            OpenSource-based Thin Client Technology
System Developer         Telephone: +46-13-21 46 00
Cendio AB                Web: http://www.cendio.com

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 251 bytes
Desc: OpenPGP digital signature
URL: <http://lists.freedesktop.org/archives/pulseaudio-discuss/attachments/20070417/31ce184c/attachment.pgp>

More information about the pulseaudio-discuss mailing list