[pulseaudio-discuss] Zeroconf-publish fails to run

Rémi Cardona remi at gentoo.org
Thu Aug 16 01:15:21 PDT 2007

Lennart Poettering wrote:
> At two places:
>    get_service()
> and in:
>    pa__init()

Attached patches to try and fix it ... the utf8 stuff is "borrowed" from
glib. I haven't actually tried it with UTF-8 data, but it should be ok.

I saw that the utf8 functions in pulse came from glib so I thought it'd
be ok to copy some more from there.

> (And while we're at it. Avahi's current implementation of
> avahi_alternative_service_name() which generates an alternative
> service name when a name conflict happens and basically just attaches 
> " #2", " #3" to it, generates a 66 character string when you pass a 63
> character string to it. Which is obviously a bug in Avahi. I've posted
> this as bug #151 in avahi BT now.)

I tried looking through avahi, but it seems that the function used in
avahi counts chars using strlen() which isn't utf8 aware either. Either
way, avahi could also use something like the first patch to count UTF8
chars properly.

But this is just with a quick look :) I could be way off.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: pa-1-utf8.patch
Type: text/x-patch
Size: 2020 bytes
Desc: not available
URL: <http://lists.freedesktop.org/archives/pulseaudio-discuss/attachments/20070816/bb8f77cf/attachment.bin>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: pa-2-truncate.patch
Type: text/x-patch
Size: 1630 bytes
Desc: not available
URL: <http://lists.freedesktop.org/archives/pulseaudio-discuss/attachments/20070816/bb8f77cf/attachment-0001.bin>

More information about the pulseaudio-discuss mailing list