[pulseaudio-discuss] New Pulseaudio Problems

Paul Jones raptorman18 at gmail.com
Mon May 28 19:28:19 PDT 2007

Hi, I've been using Pulseaudio almost flawlessly for most of this year and I
must say it usually works like a dream. It is truly good work.

However recently I was forced to reinstall my Debian after the nvidia
installer broke my system beyond my abilities to repair it. So obviously it
was the first time I installed a Debian "Lenny" disc and it went flawlessly.
Once installed I ran a script which downloads all the programs I use and I
later compiled a custom 2.6.21 kernel with tickless system, voluntary
preemption, no paravirtualization, and no nvidia frame buffer drivers. I was
then able to successfully install nvidia drivers from Debian.

However, now my pulseaudio sound server no longer works as I expect it to.

One of the problems I am having is with Iceweasel. With the sound server on
I cannot get flash sound. I have the compatibility module installed, but
still nothing. I have had a perfect setup before so I do not think there is
anything I am doing wrong.

However, I should mention that I did have flash sound working, but the sound
wasn't synchronized with the video. I used to have perfect synchronization
with pulseaudio and flash videos. I do remember that my flash videos used to
go out of sync when the pulseaudio daemon crashed and I would restart it
from the terminal. Whenever I had to do that flash videos would be out of
sync until I rebooted and pulseaudio would start automatically. Now since I
have been playing with it I have broken it completely it just says "UNABLE
TO CREATE STREAM". I've tried several purges or iceweasel and flash, editing
the config files in /etc/pulse does nothing either.

That is part of the problem. When I look at running processes pulseaudio is
no longer listed like it used to be. I figured out how to get pulseaudio to
start automatically by editing /etc/default/pulseaudio. Anyway, the file
says /etc/default/pulseaudio isn't even the recommended way of getting
pulseaudio to start automatically. And at sometimes when I don't have
pulseaudio starting automatically and I try to start it automatically from a
terminal it simply will not start. I do not think it is my kernel because I
have had pulseaudio working on a very similar custom kernel.

Sorry for the long back story but I think it was the best way of explaining
my situation. I also cannot get gnome sounds working anymore but that is of
a lower priority because I can live without that. What has changed in
pulseaudio since February I guess that causes this.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/pulseaudio-discuss/attachments/20070528/9a5056c9/attachment.htm>

More information about the pulseaudio-discuss mailing list