[pulseaudio-discuss] Splitting a sound card

Lennart Poettering lennart at poettering.net
Wed Sep 12 07:02:57 PDT 2007

On Tue, 04.09.07 10:49, Tanu Kaskinen (tanuk at iki.fi) wrote:

> On Mon, Sep 03, 2007 at 09:15:06PM +0200, Lennart Poettering wrote:
> > Hmm, module-alsa-sink doesn't support your card? how so?
> Ticket #31. (You can safely skip the rest of this message :)
> > What happens?
> IIRC the alsa module gives an error somewhat like this:
> "Unable to set hardware parameters: Operation not permitted"
> Actually, I didn't find out about this until last thursday.
> Last week in IRC somebody had problems using pulseaudio.
> Sound was being played too fast. The sound card was similar
> to mine, it used the same chip, so I was able to guess that
> it was a hardware quirk that I had run into earlier, and
> could be fixed in alsamixer. In addition to that it turned
> out that the module-alsa-sink wasn't able to use the card,
> "Operation not permitted", only device=default (ie. dmix)
> worked. That was very strange, after all every other alsa
> application was apparently working and my card sure worked
> just fine... except that a bit later, for an unrelated
> reason, I tried to load the module-alsa-sink myself, and it
> turned out that actually I had never done that before. I had
> always used the module-jack-sink...
> I hope I didn't bore you with this little anecdote :)

Looks like a bug to me that needs to be fixed. Could you please check
which function exactly causes the EPERM?

An strace would be useful, too.

Also, could you try to reproduce the issue with "aplay -D hw:0" and
playing around with the sampling parameters?


Lennart Poettering                        Red Hat, Inc.
lennart [at] poettering [dot] net         ICQ# 11060553
http://0pointer.net/lennart/           GnuPG 0x1A015CC4

More information about the pulseaudio-discuss mailing list