[pulseaudio-discuss] pulseaudio cannot recognise ALSA plughw

kaworu fw kaworufw at gmail.com
Mon Dec 22 10:59:46 PST 2008

Hi Lennart,

I've further compiled pulseaudio 0.9.10 and that version can open the same
device (plughw:2) with the ALSA version in Fedora 10.  Do you think if it is
related to the new timing mechanism after 0.9.10?


I: core-util.c: Successfully gained nice level -11.
I: main.c: This is PulseAudio 0.9.10
I: main.c: Page size is 4096 bytes
I: main.c: Fresh high-resolution timers available! Bon appetit!
E: shm.c: Invalid shared memory segment size
I: module-alsa-sink.c: Successfully opened device plughw:2.
I: module-alsa-sink.c: Successfully enabled mmap() mode.
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL plughw:2
I: alsa-util.c: Unable to attach to mixer plughw:2: No such file or
I: alsa-util.c: Unable to attach to mixer hw:(null): No such device
I: sink.c: Created sink 0 "alsa_output.plughw_2" with sample spec "s16le 2ch
I: source.c: Created source 0 "alsa_output.plughw_2.monitor" with sample
spec "s16le 2ch 44100Hz"
I: module-alsa-sink.c: Using 4 fragments of size 4408 bytes.
D: module-alsa-sink.c: Thread starting up
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+29
I: module-alsa-sink.c: Starting playback.
I: module.c: Loaded "module-alsa-sink" (index: #0; argument:
"device=plughw:2 ").

On Tue, Dec 16, 2008 at 11:55 PM, kaworu fw <kaworufw at gmail.com> wrote:

> Further I do hear noise coming out when I run the following command as you
> suggested in http://www.pulseaudio.org/ticket/355
> That's mean ALSA is able to convert S32 to packed S24.
> aplay -D plug:hw:1 -f S32_LE -r 48000 -c 2 < /dev/urandom
> ---------- Forwarded message ----------
> From: kaworu fw <kaworufw at gmail.com>
> Date: Tue, Dec 16, 2008 at 11:44 PM
> Subject: Re: [pulseaudio-discuss] pulseaudio cannot recognise ALSA plughw
> To: General PulseAudio Discussion <pulseaudio-discuss at mail.0pointer.de>
> Hi Lennart,
> Thanks. I'll try.
> On the other hand I suppose my sound card (EMU 0404 USB) only supports
> 24bit with MMAP interleaved.... Do you think it is the cause of the
> problem?  However the same setup works fine when I was using Fedora 9....
> but it doesn't work in Fedora 10 now.  I also tried tsched=0 but no luck as
> well.
> Cheers,
> Tabris
> On Thu, Dec 11, 2008 at 2:31 AM, Lennart Poettering <
> lennart at poettering.net> wrote:
>> On Wed, 10.12.08 22:22, kaworu fw (kaworufw at gmail.com) wrote:
>> > Hi Lennart,
>> >
>> > Thanks for your suggestion.  However passing mmap=0 to module-alsa-sink
>> > doesn't bring me any luck to make it work.
>> >
>> > I will report this to ALSA people.  On the other hand how can I get more
>> > information from PA to pass to the ALSA people?
>> Hmm, it might be good idea to use ltrace to list the ALSA calls made.
>> Lennart
>> --
>> Lennart Poettering                        Red Hat, Inc.
>> lennart [at] poettering [dot] net         ICQ# 11060553
>> http://0pointer.net/lennart/           GnuPG 0x1A015CC4
>> _______________________________________________
>> pulseaudio-discuss mailing list
>> pulseaudio-discuss at mail.0pointer.de
>> https://tango.0pointer.de/mailman/listinfo/pulseaudio-discuss
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/pulseaudio-discuss/attachments/20081223/b34bd9d9/attachment.htm>

More information about the pulseaudio-discuss mailing list