[pulseaudio-discuss] 0.9.8 pthread error?

Jim Duda jim at duda.tzo.com
Fri Feb 29 05:59:21 PST 2008

Thanks for the reply.  FC7 currently has 1.5.22.

Installed Packages
libtool-ltdl.i386                           1.5.22-11.fc7          installed
libtool-ltdl-devel.i386                  1.5.22-11.fc7          installed

"Colin Guthrie" <gmane at colin.guthr.ie> wrote in message news:fq8ib4$sk8$1 at ger.gmane.org...
> Tanu Kaskinen wrote:
>> On Thu, Feb 28, 2008 at 05:45:12PM -0500, Jim Duda wrote:
>>> /usr/local/bin/pulseaudio results in this error:
>>> pulseaudio: pulsecore/mutex-posix.c:98: pa_mutex_unlock: Assertion `pthread_mutex_unlock(&m->mutex) == 0' failed.
>>> version 0.9.6, installed via yum works fine.
>>> What could I be missing?
>> This is the same assertion that was hit in Debian when it
>> had a broken version of libltdl3-dev (1.5.22). I believe
>> this was supposed to be entirely Debian specific, but make
>> sure you have at least version 1.5.24 of libltdl3-dev
>> anyway. (F7 might not have a package named like that,
>> though. libltdl is part of libtool.)
> FWIW, pa 0.9.8 needs libltdl > 1.5.22 (or at least != 1.5.22). Other
> distros had this too (at least we had it also on Mandriva and I'm sure
> I've seen others ask about this too).
> Col 

More information about the pulseaudio-discuss mailing list