[pulseaudio-discuss] getting pulseaudio working on fedora 9

Don Raikes don at draikes.com
Tue Jul 15 11:30:29 PDT 2008


I just installed fedora 9 last night. As a blind user, I need the audio
output to work both for console applications as well as for the gnome

I am having problems getting pulseaudio to work.

When I run:
$ pulseaudio 
as a regular user, I get:

N: main.c: Called SUID root and real-time/high-priority scheduling was requested in the configuration. However, we lack the necessary priviliges:
N: main.c: We are not in group 'pulse-rt' and PolicyKit refuse to grant us priviliges. Dropping SUID again.
N: main.c: For enabling real-time scheduling please acquire the appropriate PolicyKit priviliges, or become a member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.
W: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
W: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
E: main.c: daemon startup without any loaded modules, refusing to work.

When I run:
$ aplay -l
I get:

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC880 Analog [ALC880 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: default [C-Media USB Headphone Set  ], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

It is a critical part of my job that I get this system working so any
help would be greatly appreciated.

Don Raikes - Accessibility Specialist

More information about the pulseaudio-discuss mailing list