[pulseaudio-discuss] pulseaudio, snd-hda-intel issues solved.

Sean McNamara smcnam at gmail.com
Tue Jul 22 12:17:17 PDT 2008

Interesting results, Jack. I am using Ubuntu 8.10 Alpha 2, which ships
the final stable 2.6.26 kernel with Ubuntu patches. Impressively,
Ubuntu still thinks they should ship ALSA 1.0.16 with their next
release, or at least they haven't updated to 1.0.17 - so I basically
checked out the entire ALSA package (alsa-lib,
alsa-driver/alsa-kmirror, alsa-plugins) from GIT master and built 'em.
So I was running a post-1.0.17 version with the patches pre-applied
because Takashi committed them on the 18th.

I have an ICH8-based snd-hda-intel card in my ThinkPad X61. In
addition to the latest GIT alsa, I am using the latest GIT pulseaudio.
Although I had some issues getting it to run system-wide, I haven't
unearthed any distortion or static yet! I have just been using
Rhythmbox, Flash, and Pidgin as my main PA clients (or ALSA<->PA, as
the case may be) -- the only thing I notice is that most streams,
except paplay which is always perfect, have a brief dropout at the
beginning. It isn't a periodic dropout, I played a 10 minute long MP3
and indeed, the only dropout for the duration of the stream was at the
beginning! I tried fiddling with fragment sizes in daemon.conf after I
experienced this problem, but haven't had any luck yet.

So to sum it up, I'm not able to reproduce your problem with static or
distortion, but I do have a minor playback quality issue which seems
to always haunt snd-hda-intel (since PA 0.9.0 or even earlier)....
maybe it's softvol again :D

And, if I don't use system-wide daemon, I still get the single dropout
in the beginning; it's just a lot shorter in duration when the program
is using the native-unix protocol over SHM than when the stream is
connected to localhost over inet4.

Do you think you could try building ALSA from git? There have been a
few commits against the intel driver since 1.0.17, and you won't be
any worse off with the rewind patches since they are committed. It's
pretty easy; just do something like this

mkdir alsa-git
cd alsa-git
git clone git://git.alsa-project.org/alsa-driver.git alsa-driver
git clone git://git.alsa-project.org/alsa-kmirror.git alsa-kmirror
git clone git://git.alsa-project.org/alsa-lib.git alsa-lib
git clone git://git.alsa-project.org/alsa-plugins.git alsa-plugins
git clone git://git.alsa-project.org/alsa-utils.git alsa-utils   [[optional]]
cd alsa-driver
./gitcompile; sudo make install
cd ../alsa-lib
./gitcompile; sudo make install
cd ../alsa-plugins
./gitcompile; sudo make install
cd ../alsa-utils
./gitcompile; sudo make install

It'll install everything in /usr/ by default rather than /usr/local so
don't worry.



On Tue, Jul 22, 2008 at 6:53 AM, Jack Howarth <howarth at bromo.msbb.uc.edu> wrote:
>   It turned out the problem I was having was that pulseaudio 0.9.11
> (even with the three patches posted recently to alsa-devel) still has
> issues under Fedora 9. When I regressed back to pulseaudio 0.9.10 and
> used the latest 2.6.26-git6 kernel which has the alsa 1.0.17 drivers,
> audio works fine now.
>             Jack
> ps What I get under pulseaudio 0.9.11 is distortion and static in
> the audio playback.
> _______________________________________________
> pulseaudio-discuss mailing list
> pulseaudio-discuss at mail.0pointer.de
> https://tango.0pointer.de/mailman/listinfo/pulseaudio-discuss

More information about the pulseaudio-discuss mailing list