[pulseaudio-discuss] Assertion in module-oss

Lennart Poettering lennart at poettering.net
Sun Jul 27 06:31:34 PDT 2008

On Sun, 27.07.08 11:45, Stanley Cai (stanley.w.cai at gmail.com) wrote:

> Hi,
> I built PulseAudio 0.9.11 on ubuntu 8.04, without any special
> parameters.  As I ran as "pulseaudio -v" and used pacat for testing,
> an assertion jumped out. Here is my log:

> I: client.c: Created 0 "Native client (UNIX socket client)"
> I: protocol-native.c: Got credentials: uid=1000 gid=1000 success=1
> I: module-volume-restore.c: Restoring sink for
> <pulsecore/protocol-native.c$pacat>
> I: module-volume-restore.c: Restoring volume for
> <pulsecore/protocol-native.c$pacat>
> I: module-oss.c: Trying resume...
> E: module-oss.c: Assertion 'u->mixer_devmask & ((1 << 0)|(1 << 4))'
> failed at modules/module-oss.c:785, function sink_get_volume().
> Aborting.
> ----end of log----
> when I disabled "module-suspend-on-idle", it worked well at least
> "pacat < /dev/urandom".
> Is it a new issue? As I am a newbie to pulseaudio, any help is very appreciated.

This seems to be some strangeness in your audio driver. When PA
initialized itself it made sure that the mixer device had at least a
PCM or master volume track. When PA came back from the suspend and
opened the audio device again those tracks were gone! This means
either that your sound driver is buggy, or that the device files were
shuffled around (due to hotplug?).

But why do you use OSS anyway? Use ALSA and the default configuration.


Lennart Poettering                        Red Hat, Inc.
lennart [at] poettering [dot] net         ICQ# 11060553
http://0pointer.net/lennart/           GnuPG 0x1A015CC4

More information about the pulseaudio-discuss mailing list