[pulseaudio-discuss] RTP segfault/uninitialized resampler in pulse 0.9.14 ?

Erich Boleyn erich at uruk.org
Tue Feb 3 10:29:22 PST 2009

Erich Boleyn <erich at uruk.org> wrote:

[most edited out for brevity]

> Details:
>   --  Gentoo 2.6.25 kernel
>   --  Pulseaudio 0.9.14, ebuild sets config as (I think..., this seems
>       to correspond to my "use" gentoo options):
>         --enable-largefile --disable-solaris --enable-alsa --enable-glib
>         --enable-tcpwrap --localstatedir=/var --disable-ltdl-install
>       (tried with/without --enable-samplerate  and got the same results )
>   --  Pulseaudio config not using module-hal-detect, so I had to initialize
>         the "module-alsa-source" and "module-alsa-sink" modules by hand
>         to get around the "tsched=0" glitch-free issue.

Sorry, being more explicit about the above line, which I realized later
is rather vague:

  --  Pulseaudio config file was the standard one for system daemon mode
      ("system.pa") except I removed the "module-detect", and replaced
      it with:

	load-module module-alsa-source device=hw:0 tsched=0
	load-module module-alsa-sink device=hw:0 tsched=0

      ...and added the following rtp receiver line at the end
      for my test case which demonstrates the crash at the first
      resampler update:

	load-module module-rtp-recv sap_address= sink=alsa_output.hw_0

In a different test, I tried a few other receiver sinks ("module-combine"
and "module-null-sink") and the problem occurs there as well.

    Erich Stefan Boleyn     <erich at uruk.org>     http://www.uruk.org/
"Reality is truly stranger than fiction; Probably why fiction is so popular"

More information about the pulseaudio-discuss mailing list