[pulseaudio-discuss] Using PA with multiple sound cards

Mark Greenwood fatgerman at ntlworld.com
Sat Mar 21 16:45:23 PDT 2009

On Saturday 21 March 2009 08:27:56 Colin Guthrie wrote:
> I have no idea why pavucontrol running would cause things to stablise 
> but closing it causes things to go awry :s
> If you can perhaps provide a simple series of steps including 
> pactl/pacmd commands to get the same setup as you then I or other users 
> can test and confirm things?

Yeah I forget there are multiple ways to set this up, and I really should know how to write useful bug reports, so sorry for that.

RTP Problem:

Machine one: I have used paprefs to 'Enable Multicast/RTP receiver'.

Machine two: I've used paprefs to 'Enable Multicast/RTP sender' and 'Create separate audio device for Multicast/RTP'.
This machine is running KDE4 (don't know if that's relevant though) so I've configured Phonon to use Pulseaudio as the default device for 'Music'. Start Amarok playing some music. This comes out of my local speakers. Start pavucontrol and Move Stream of amarok to 'RTP Multicast Sink'. Audio goes away from local speakers and starts coming out of remote speakers. Nice.

Close pavucontrol. Audio immediately becomes choppy, often dropping out for several seconds. Start pavucontrol again, audio comes back.

High CPU usage problem:

Machine one: Use paprefs to enable 
'Enable network access to local sound devices'
'Allow other machines on the LAN to discover local sound devices'
'Don't require authentication'

Machine two: Use paprefs to enable
'Make discoverable network sound devices available locally'

As before, start Amarok playing some music. Use pavucontrol to Move Stream to the USB sound device on machine one (actually it doesn't matter, any device on machine one will do. I don't even need the USB device plugged in).

Audio starts playing out of machine one. CPU usage (run 'top') on both machines rises and rises. Machine one is very low-powered and on there the CPU usage reaches 99% and pulseaudio quits.

With PulseAudio 0.9.10 this all worked perfectly. I have only upgraded Machine two. It's broken in 0.9.14 and later but I haven't tried the intervening versions. I should point out that the change in version of PulseAudio is also a change in release of Linux distributions so all the other stuff (paprefs, pavucontrol) is also newer. Also, don't know if it matters, but the source machine is now running 64-bit. When it had 0.9.10 it was running 32 bit.

This is the best thing about Linux when it works. I'm starting to think I'm going mad; (I can't be the only one using the network stuff, 
surely? Why has nobody else reported this?) If someone could verify it (or refute it completely) I'd be extremely grateful and it will motivate me to try more experiments and help to pin it down.



> Col

More information about the pulseaudio-discuss mailing list