[pulseaudio-discuss] Moving speakers around using AC3

Aurelien Bompard gauret at free.fr
Sun Nov 29 02:38:46 PST 2009

Le dimanche 29 novembre 2009, Michał Sawicz a écrit :
> Dnia 2009-11-29, nie o godzinie 09:13 +0100, Aurelien Bompard pisze:
> > That's what I tried to do. But it looks like the udev-autodetect
> > module
> > prevents adding something else by hand. It is the case ?
> It shouldn't, try using pacmd on a running instance, adding a
> module-alsa-sink.

I ran this command :
  pacmd load-module module-alsa-sink sink_name=upmixer device=upmixer
but it looks like it failed (no error message on the command line), and I 
got this in syslog (I set pulseaudio to "debug" log level) :
pulseaudio[13966]: main.c: Signal SIGUSR2 obtenu.
pulseaudio[13966]: module.c: Loaded "module-cli-protocol-unix" (index: #17; 
argument: "").
pulseaudio[13966]: client.c: Created 5 "UNIX socket client"
pulseaudio[13966]: alsa-util.c: Device upmixer doesn't support 44100 Hz, 
changed to 48000 Hz.
pulseaudio[13966]: alsa-sink.c: Successfully opened device upmixer.
pulseaudio[13966]: alsa-sink.c: Cannot enable timer-based scheduling, 
falling back to sound IRQ scheduling.
pulseaudio[13966]: alsa-sink.c: Successfully enabled mmap() mode.
pulseaudio[13966]: sink.c: Created sink 1 "upmixer" with sample spec s16le 
2ch 48000Hz and channel map front-left,front-right
pulseaudio[13966]: sink.c:     alsa.resolution_bits = "16"
pulseaudio[13966]: sink.c:     device.api = "alsa"
pulseaudio[13966]: sink.c:     device.class = "sound"
pulseaudio[13966]: sink.c:     alsa.class = "generic"
pulseaudio[13966]: sink.c:     alsa.subclass = "generic-mix"
pulseaudio[13966]: sink.c:     alsa.name = "Filter_A52Encode"
pulseaudio[13966]: sink.c:     alsa.id = "Filter_A52Encode"
pulseaudio[13966]: sink.c:     alsa.subdevice = "0"
pulseaudio[13966]: sink.c:     alsa.subdevice_name = "Filter_A52Encode"
pulseaudio[13966]: sink.c:     alsa.device = "0"
pulseaudio[13966]: sink.c:     device.string = "upmixer"
pulseaudio[13966]: sink.c:     device.buffering.buffer_size = "18432"
pulseaudio[13966]: sink.c:     device.buffering.fragment_size = "6144"
pulseaudio[13966]: sink.c:     device.access_mode = "mmap"
pulseaudio[13966]: sink.c:     device.description = "Filter_A52Encode"
pulseaudio[13966]: sink.c:     device.icon_name = "audio-card"
pulseaudio[13966]: source.c: Created source 2 "upmixer.monitor" with sample 
spec s16le 2ch 48000Hz and channel map front-left,front-right
pulseaudio[13966]: source.c:     device.description = "Monitor of 
pulseaudio[13966]: source.c:     device.class = "monitor"
pulseaudio[13966]: source.c:     device.icon_name = "audio-input-microphone"
pulseaudio[13966]: alsa-sink.c: Using 3,0 fragments of size 6144 bytes 
(32,00ms), buffer size is 18432 bytes (96,00ms)
pulseaudio[13966]: core-util.c: Successfully enabled SCHED_RR scheduling for 
thread, with priority 5.
pulseaudio[13966]: alsa-sink.c: Starting playback.
pulseaudio[13966]: (alsa-lib)pcm_hw.c: SNDRV_PCM_IOCTL_START failed
pulseaudio[13966]: module.c: Loaded "module-alsa-sink" (index: #18; 
argument: "sink_name=upmixer device=upmixer").
pulseaudio[13966]: client.c: Freed 5 "UNIX socket client"
pulseaudio[13966]: alsa-sink.c: Assertion 'err != -11' failed at 
modules/alsa/alsa-sink.c:395, function try_recover(). Aborting.
pulseaudio[14001]: core-util.c: Successfully gained nice level -11.
The last line show that pulseaudio is being restarted after the "Aborting".
Is it because of the "(alsa-lib)pcm_hw.c: SNDRV_PCM_IOCTL_START failed" ?  
Or because of the "Assertion 'err != -11' failed at modules/alsa/alsa-
sink.c:395, function try_recover()" ?

Any idea where this could come from ? If I can help in any way, please tell.

http://aurelien.bompard.org  ~~~~  Jabber : abompard at jabber.fr
"There are 10^11 stars in the galaxy. That used to be a huge number.
But it's only a hundred billion. It's less than the national deficit!
We used to call them astronomical numbers. Now we should call them
economical numbers." -- Richard Feynman

More information about the pulseaudio-discuss mailing list