[pulseaudio-discuss] 0.9.17 regression: USB device disappears after suspend/resume

Colin Guthrie gmane at colin.guthr.ie
Mon Sep 14 03:01:47 PDT 2009

'Twas brillig, and Cameron Hutchison at 13/09/09 22:49 did gyre and gimble:
> Lennart Poettering <lennart at poettering.net> writes:
>>> D: alsa-util.c: Got POLLERR from ALSA
>>> W: alsa-util.c: Got POLLNVAL from ALSA
>> This suggests that your driver does not survive the suspend/resume due
>> to some reason. Is it possible that you also updated the kernel at the
>> same time as updating PA?
> I had updated the kernel to 2.6.31, but I tried rolling back to
> and I still had the problem. Suspend/resume worked with PA 0.9.15 and
> I get the reported problem with PA 0.9.17 with both
> and 2.6.31.

Hmm, would you be able to get full pulseaudio -vvv output during the 
suspend/resume cycle?

Lennart, perhaps the rate limiter thing is preventing smooth resuming?

FWIW, personally, I've just resumed here (I plugged USB in before 
opening lid) and my USB speaker set appeared fine...



Colin Guthrie

Day Job:
   Tribalogic Limited [http://www.tribalogic.net/]
Open Source:
   Mandriva Linux Contributor [http://www.mandriva.com/]
   PulseAudio Hacker [http://www.pulseaudio.org/]
   Trac Hacker [http://trac.edgewall.org/]

More information about the pulseaudio-discuss mailing list