[pulseaudio-discuss] pulseaudio daemon toggling Alsa SPDIF setting every time

Lennart Poettering lennart at poettering.net
Mon Sep 14 06:42:58 PDT 2009

On Mon, 14.09.09 13:04, John Carlyle-Clarke (john at wormdrive.net) wrote:

> Hi-
> I have pulseaudio 0.9.15 and alsa 1.0.21 on Archlinux (x86_64).   
> Everything was working fine, but recently I started getting no sound in  
> pulse and - when I tried to debug - nothing in Alsa either.  I have two  
> cards - an onboard nVidia device which I don't use, and a PCI  
> Soundblaster Audigy 2 which I use as my default.  The problems may have  
> coincided with an upgrade of Alsa from 1.0.20 -> 1.0.21 but I can't be 
> sure.
> I tracked down the exact problem, and it is that every time the pulse  
> daemon starts, it toggles an SPDIF output flag on my sound card's Alsa  
> setup.  This effectively disables analog audio.  I tried deleting the  
> contents of ~/.pulse in case it was restoring some remembered settings  
> each time, but no joy.
> If I untoggle that setting after pulseaudio starts, everything is OK  
> (until next time pulseaudio starts, that is).
> If anyone can cast some light on the problem or suggest something else I  
> can test, please do!

PA is probably simply configuring your card into the SPDIF
profile. Use a recent g-v-c or pavucontrol version, got to the
"Configuration" tab and select the profile you want to use for your card.


Lennart Poettering                        Red Hat, Inc.
lennart [at] poettering [dot] net
http://0pointer.net/lennart/           GnuPG 0x1A015CC4

More information about the pulseaudio-discuss mailing list