[pulseaudio-discuss] Missing Digital outputs with hotplug Transit device

Colin Guthrie gmane at colin.guthr.ie
Sun Sep 27 05:11:04 PDT 2009

'Twas brillig, and Neil Wilson at 27/09/09 11:42 did gyre and gimble:
> 2009/9/27 Colin Guthrie <gmane at colin.guthr.ie>:
>> What version of udev do you have? You should have at least 146 but if you
>> are on 145 then you should apply this patch:
>> http://cvs.fedoraproject.org/viewvc/rpms/udev/devel/0001-enumeration-move-ALSA-control-devices-to-the-end-of-.patch?revision=1.1&view=markup
>> (it is included in udev 146)
>> Hope that's the problem.
> Doesn't look like it. I'm on the edge with Ubuntu karmic, which is
> pulseaudio 0.9.18 and udev 147 and yes it is the 'module-udev-detect'
> that is doing the lookup.

Well regardless of the cause, I think the symptom is still the same. 
There is a race somewhere relating to the device permissions. It could 
be udev or consolekit or kernel level inotify support to blame, but I 
don't think it's pulse specifically (tho' that could very easily be 
wrong - or it could be that this is where it needs to be worked around 
in any case).



Colin Guthrie

Day Job:
   Tribalogic Limited [http://www.tribalogic.net/]
Open Source:
   Mandriva Linux Contributor [http://www.mandriva.com/]
   PulseAudio Hacker [http://www.pulseaudio.org/]
   Trac Hacker [http://trac.edgewall.org/]

More information about the pulseaudio-discuss mailing list