[pulseaudio-discuss] Does pulseaudio require alsa/oss

John Frankish j-frankish at slb.com
Wed Apr 21 04:55:15 PDT 2010

-----Original Message-----
From: pulseaudio-discuss-bounces at mail.0pointer.de [mailto:pulseaudio-discuss-bounces at mail.0pointer.de] On Behalf Of Colin Guthrie
Sent: Wednesday, 21 April, 2010 11:51
To: pulseaudio-discuss at mail.0pointer.de
Subject: Re: [pulseaudio-discuss] Does pulseaudio require alsa/oss

'Twas brillig, and John Frankish at 21/04/10 07:15 did gyre and gimble:
> OK, now that's clear, I tried the following with:
> $ cat /proc/asound/cards 0 [Intel          ]: HDA-Intel - HDA Intel 
> HDA Intel at 0xefebc000 irq 28
> kernel
> pulseaudio-0.9.21 patched
> Subject: [PATCH] udev: handle sound cards with both modem and audio
> properly Subject: [PATCH] udev: rework modem detection a bit
> [copy 90-pulseaudio.rules /etc/udev/rules.d]

FWIW, you probably want a lot more patches than that. Basically anything
that's in the stable-queue git branch.

What distro is this? Generally speaking your distro maintainer will make
sure you have a working setup OOTB.


> Basically module-udev-detect does not find any sound devices. If I
> use module-detect, then the sound device is found, but
> gstreamer-properties does not show any pulseaudio source.

So it should just show a generic "PulseAudio Sound Server". If you don't
have this, then have you got the necessary packages installed. e.g.
gstreamer-pulse or gstreamer0.10-pulse or similar?

You are not expected to see all the individual devices Pulse knows
about, just a generic "PulseAudio" listing.

If you don't have this listing in gstreamer-properties, then you're
gstreamer was perhaps built without PA support or you don't have all the
necessary packages installed as mentioned above.

Thanks - I'd forgotten to use the gst-plugins-good I recompiled with pulseaudio support - pulseaudio now shows up in gstreamer-properties

> I also tried after pairing Bluetooth a2dp headphones -
> module-bluetooth-discover finds the headphones, but
> gstreamer-properties does not show any pulseaudio source and thus I
> cannot use rhythmbox to play to the headphones.

As said above, you do not set things up like this in gstreamer. It
should just be configured to use "pulseaudio" generally. You then use a
real-time PA mixer app like pavucontrol or kmix from KDE trunk. These
programs list the active "streams" (e.g. what is currently being played
in Rhythmbox) and allow you to move the stream to the device of your choice.

OK - I had a look at pavucontrol, which requires a whole bunch of *mm bloat. I'll get started on compiling all this.

> I can set the
> headphones as the default alsa device in .asoundrc, but this bypasses
> pulseaudio and is not the object of the exercise.

As you note, this is very much not the way to do things :p

> ""). D: cli-command.c: Checking for existance of
> '/usr/local/lib/pulse-0.9.21/modules/module-udev-detect.so': success 
> I: module-udev-detect.c: Found 0 cards. I: module.c: Loaded
> "module-udev-detect" (index: #4; argument: "").

Something seems wrong here... I suspect your udev setup is somehow
broken but I'm not an expert WRT udev so can't really say for sure.

I agree something's not right, but my udev setup works for everything else...

One other strange problem I have, which is not (very) repeatable is:

$ pulseaudio -vv
E: module-console-kit.c: GetSessionsForUnixUser() call failed: org.freedesktop.DBus.Error.Spawn.ChildExited: Launch helper exited with unknown return code 0
E: module.c: Failed to load  module "module-console-kit" (argument: ""): initialization failed.
E: main.c: Module load failed.
E: main.c: Failed to initialize daemon.

As seen from my last post, this doesn't happen all the time, but I don't know how to fix it when it does.


More information about the pulseaudio-discuss mailing list