[pulseaudio-discuss] ACLs for USB devices on Debian GNU/Linux Squeeze/testing

Colin Guthrie gmane at colin.guthr.ie
Thu Aug 19 10:15:26 PDT 2010

'Twas brillig, and Frode Severin Hatlevik at 19/08/10 17:47 did gyre and
> 2010/8/8 Frode Severin Hatlevik <frodeseverin at gmail.com>:
>> First of all, I will like to say thank you for a great piece of
>> software. PulseAudio makes sound a mor pleasant experinence.
>> Now to my problem. It is not with PA itself, but rather a matter of
>> setting up my system to make things work. I have several USB devices;
>> all from Logitech, incidently; that I want to use with my laptop. I am
>> using Debian GNU/Linux Squeeze/testing on an i686 kernel.
>> Before using PA I had my users in the "audio" group. After using PA
>> for a while I removed all users from the "audio" group, and this
>> solved all issues with user switching. I will try to reflect this in
>> the Debian Wiki after successfully sorting out my present issue. The
>> Debian wiki page for sound seems rather dated; it does not mention PA
>> at all.
>> After purging users from the "audio" group I am no longer able to use
>> my USB sound devices; nether my headset nor the mic on my webcam works
>> anymore, they simlly disappeared form the PA subsystem. The devices
>> worked befor the purge. I have been advised that this is due to the
>> lack of ACLs for the device nodes in /dev/snd, but I am at a loss in
>> how to set this up in Debian. I understand that configuring the
>> devicenodes is a task for the hotplug system together with udev and
>> ConsoleKit, but I have little experience with setting theese up.
> <snip />
> I have now figured this one out for myself.


> It turned out to be quite
> simple. I only needed to add a file, say 60-sound.rules containing the
> following line:
> Then I issued "udevadm trigger" and things started working.
> It is important to note that this rule should be numbered below 70, as
> the standard udev rule dealing with ACL is
> /lib/udev/rules.d/70-acl.rules
> at least on my Debian Squeeze/testing. Thus the matching needs to be
> done prior to the execution of this rule.

Hmm, strange.. I'm not sure what your /lib/udev/rules.d/70-acl.rules has
in it but mine has:
[colin at jimmy udev]$ grep sound.*ACL_MANAGE /lib/udev/rules.d/70-acl.rules

> I will file this as a bug in Debian BTS. Should this udev-trick be
> included in the guide for packaging PA?

Well from what I can tell the official 70-acl.rules has this line in it
already.... (certainly in udev-153 but I'm pretty certain it's been like
this for a while).

Not sure if you're Debian version is altered or something but it smells
like a debian specific bug.




Colin Guthrie

Day Job:
  Tribalogic Limited [http://www.tribalogic.net/]
Open Source:
  Mandriva Linux Contributor [http://www.mandriva.com/]
  PulseAudio Hacker [http://www.pulseaudio.org/]
  Trac Hacker [http://trac.edgewall.org/]

More information about the pulseaudio-discuss mailing list