[pulseaudio-discuss] Help: Pulseaudio networking almost OK, tunnel KO

Yves (theYinYeti) pa.ml at yeti.selfip.net
Sat May 22 04:19:57 PDT 2010

Le 14/05/2010 20:23, Yves (theYinYeti) a écrit :
> Hello,
> I'm new on this mailing-list. I tried asking this question on
> general-purpose forums, but I realise this is too specific. I hope this
> place is better suited.
> I have my own server. And I thought it would be nice to have this server
> hooked up to the HiFi, and thus enable any PC on the LAN to send sound
> to the HiFi!
> Setup was not straightforward, none the least because Mandriva's paprefs
> seems to be partly broken, and there's ZERO documentation on Pulseaudio
> networking on Mandriva. Still, I managed; all in all, it's just a matter of:
> — adding
> 	load-module  module-native-protocol-tcp
> 	load-module  module-zeroconf-publish
> to /etc/pulse/default.pa on the (Debian) server,
> — adding
> 	load-module  module-zeroconf-discover
> to /etc/pulse/default.pa on the (Mandriva) client,
> — managing authentication, either through ACL or with cookies.
> Alternately, the whole zeroconf parts can be replaced by a single line
> on the client side (I got this line thanks to paman; it was probably
> generated by zeroconf-discover in the first place):
> 	load-module  module-tunnel-sink server=[my_server_IP]:4713  sink=alsa_output.hw_0 format=s16le channels=2  rate=44100  sink_name=tunnel.sphinx.local.alsa_output.hw_0 channel_map=front-left,front-right
> Anyway, I still have two problems, which are probably related:
> *1/ Very chopped sound, and freezed video, when using the tunnelled sink*
> When I play a wav file with VLC, I only get an occasional bit of sound
> once in a while, even though VLC's slider seems to run fine.
> Curiously, when I play the same wav file with mplayer, the sound gets
> perfectly to the speakers. However, mplayer itself seems to be lost. It
> displays a line about like this:
> 	A:      0.1  (00.1)  of1.0  (00:01.0)    0.1%
> with no apparent trend up in the numbers and a regular flash of
> “unknown” (if I saw correctly) between the first pair of brackets.
> As for video, still with mplayer, it takes ages to actually start, and
> then, I have sound but no video, and mplayer is extremely slow to
> respond to key strokes.
> I must add that networking itself is not at fault. If, instead of
> relying on the tunnelled sink, I change of server with
> 	PULSE_SERVER=my_server mplayer ~/my_wav_file.wav
> then it is as good as with a local sink (which is not perfect, see below)…
> So it is obviously a tunnel-specific problem. Unfortunately, changing of
> PA server is not an option for me, because Mandriva's pavucontrol
> (pulseaudio 0.9.21) seems unable to connect to Debian's daemon
> (pulseaudio 0.9.10): I get an error about pa_context_get_card_info_list
> being “Not supported”.
> *2/ Spurious pauses in video playback when using local sinks*
> Now with local playback. As soon as a remote sink is available, be it
> through zeroconf, or directly with the tunnel-sink module, then /local/
> video playback on /local/ sinks with any player (VLC, mplayer, xine)
> plays fine, EXCEPT (that's a big except…) every 5 minutes or so, there's
> a more-or-less-15-second pause in playback!
> So for now, I'm back to square one, with both “module-zeroconf-discover”
> and “module-tunnel-sink” disabled on the client side (no Pulseaudio
> network)…
> Is there a Pulseaudio veteran here that would have advice, tips, or
> anything to help me?
> Thanks,


Although the problem is still there, the weirdest part of it is gone :)
My client's syslog was spammed by klogd with the following text without end:

	ata3.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
	ata3.00: cmd a0/00:00:00:00:00/00:00:00:00:00/a0 tag 0
	         cdb 00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00
	         res 51/20:03:00:00:00/00:00:00:00:00/a0 Emask 0x1 (device error)
	ata3.00: status: { DRDY ERR }

Following an Internet advice, I ran this:

	hal-disable-polling --device /dev/sr0

I guess some sort of “bus fill” was happening… Anyway, the log's quiet 
now. And more importantly, local playback is now perfect (tested with 
mplayer). Problem #2 above is gone. That leaves problem #1.

Good news is, as previously, running mplayer like this:
	PULSE_SERVER=my_server_IP mplayer movie.avi
gives the same result as local playback, which is, this time, perfect! 
(at the cost of 25 to 50% CPU just for PA on the server, and 10°C more)

But with this setup, I cannot adjust sound in the local (client) 

Bad news is, as previously, running mplayer on the tunneled sink 
(appears locally, so I can adjust levels) lets me hear audio, but I have 
no picture, and mplayer console display is kind of freezed.

Is there additional information that would help you help me?

For instance, here's the server info:
processor: CentaurHauls VIA Nehemiah 1GHz
OS: Debian 5.0.4, kernel 2.6.26-2-486
00:00.0 Host bridge: VIA Technologies, Inc. VT8623 [Apollo CLE266]
00:01.0 PCI bridge: VIA Technologies, Inc. VT8633 [Apollo Pro266 AGP]
00:0d.0 FireWire (IEEE 1394): VIA Technologies, Inc. VT6306 Fire II IEEE 
1394 OHCI Link Layer Controller (rev 80)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 
Controller (rev 80)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 
Controller (rev 80)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 
Controller (rev 80)
00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc. 
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:11.5 Multimedia audio controller: VIA Technologies, Inc. 
VT8233/A/8235/8237 AC97 Audio Controller (rev 50)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] 
(rev 74)
01:00.0 VGA compatible controller: VIA Technologies, Inc. VT8623 [Apollo 
CLE266] integrated CastleRock graphics (rev 03)

And here's the client info:
processor: dual GenuineIntel Intel(R) Core(TM)2 CPU 4300 @ 1.80GHz
OS: Mandriva Linux release 2010.0 (Official) for i586,
00:00.0 Host bridge: Intel Corporation 82945G/GZ/P/PL Memory Controller 
Hub (rev 02)
00:01.0 PCI bridge: Intel Corporation 82945G/GZ/P/PL PCI Express Root 
Port (rev 02)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High 
Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express 
Port 1 (rev 01)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express 
Port 2 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI 
Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI 
Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI 
Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI 
Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI 
Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC 
Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE 
Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family) 
SATA IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller 
(rev 01)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. 
RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)
03:00.0 VGA compatible controller: ATI Technologies Inc Radeon HD 4770 
03:00.1 Audio device: ATI Technologies Inc R700 Audio Device [Radeon HD 
4000 Series]
04:02.0 Multimedia controller: Philips Semiconductors SAA7134/SAA7135HL 
Video Broadcast Decoder (rev 01)

Thank you for any coming help,


(repost; I used the wrong address yesterday)

More information about the pulseaudio-discuss mailing list