[pulseaudio-discuss] [RFC] Allow read-only or non-existing sink input volume.

Maarten Bosmans mkbosmans at gmail.com
Sun Feb 27 11:55:13 PST 2011

2011/2/27 Colin Guthrie <gmane at colin.guthr.ie>:
> 'Twas brillig, and Tanu Kaskinen at 27/02/11 12:35 did gyre and gimble:
>> I actually have started to feel that "volume_readable" and
>> "volume_writable" would be better than "has_volume" and
>> "read_only_volume" in pa_sink_input_info. What are others' opinions? One
>> argument for "readable"/"writable" is that those terms also cover the
>> write-only case, which will probably never occur in practice, but you
>> never know...
> I did actually prefer _readable and _writeable when you mentioned them
> but didn't feel strongly enough to ask you to change them. So if you do
> prefer them, I'd be happier too if you changed them :)
> As this is in my tree now and I have merged a few other things, it will
> be a little tricky to back it out (due to doing merges since then), but
> I can do that if really needed (don't think Maaten will mind rebasing
> his win32 stuff if needed which was the merge) or you can just make your
> change on top of the current one. Let me know what you think.

Meh, I don't care either way. I have some further improvements laying
around, so they could then be merged together in one go. Rebasing in
git is actually kinda fun!

> Cheers
> Col


More information about the pulseaudio-discuss mailing list