[pulseaudio-discuss] my paulseaudio is not running as daemon

Colin Guthrie gmane at colin.guthr.ie
Tue May 17 23:59:07 PDT 2011

'Twas brillig, and Fu, Zhen at 18/05/11 07:50 did gyre and gimble:
> I need developing PA client App,so I download pulseaudio-0.9.22 and run
> “./configure,make,make install”.After install finished,I run “pacmd”,but
> display “No pulseaudio daemon running,or not running as session
> daemon”.Then,I run “ps aux | grep pulse”,but display “pulseaudio –start”.

Are you running this as root or a regular user.

What does (as a regular user) pulseaudio -vvvv say (I suspect daemon
already running or pid file already exists or similar)?

Are you using a distro? If so what version does your distro include and
did you overwrite you distro version with your self build version or is
it now installed into /usr/local instead?

Also, I would suggest the stable-queue git branch rather than 0.9.22 as
this contains several bugfixes on top of 0.9.22.



Colin Guthrie

Day Job:
  Tribalogic Limited [http://www.tribalogic.net/]
Open Source:
  Mageia Contributor [http://www.mageia.org/]
  PulseAudio Hacker [http://www.pulseaudio.org/]
  Trac Hacker [http://trac.edgewall.org/]

More information about the pulseaudio-discuss mailing list