[pulseaudio-discuss] System freeze

Daniel Mack zonque at gmail.com
Sat Nov 19 01:27:26 PST 2011

On 11/18/2011 07:23 PM, dirkydirk wrote:
> You are right, I don't know for sure if it's a PA problem at all, but I
> have to start looking somewhere ;)
> With the same result, a complete system lockup, I have tried kernels
> 3.1.0 and 2.6.37, rhythmbox and banshee (both use gstreamer),
> flashplayer 10 and 11, firefox 8. Oopses are none in the logs.

Did you try with a different sound card?

> What kind of stress tests do you have in mind?

I was thinking about heavy IO load in general, high CPU usage, all the
like. But your problem seems to be audio related.

> Before the update to gnome 3 I had an alsa-only environment, and this
> lockup did not occur. Apart from updated libraries, PA is the only new
> component in the system concerning audio, this is why I was looking here
> first. Because gnome 3 depends on PA, de-installing it to have an
> alsa-only environment again is not an option.
> I have attached the output of "pulseaudio -vvvvv". After the last line,
> the crash happened. But on a previous run, there was a different last
> line...
> Is it possible to tell gstreamer to not use pa but only alsa? 

Sure. Just use the 'alsasink' component, and temporarily disable
pulseaudio by prefixing the command with 'pasuspender'.


> On Fri, 2011-11-18 at 17:57 +0100, Daniel Mack wrote:
>> On Fri, Nov 18, 2011 at 5:35 PM, dirkydirk <dirkydirk at gmx.net> wrote:
>>> Hello,
>>> recently I have updated my debian sid box to the latest gnome 3, which
>>> installed also PulseAudio. Pleasantly, sound worked out of the box, even
>>> flash, and my sound card SB XFi-Extreme Audio is detected and used (had
>>> to use onboard sound for Linux prior to that).
>>> But alas, a big problem occurs: every time I play music via a gstreamer
>>> app (rhythmbox) and play a flash in firefox, after a minute or so the
>>> whole system freezes. I mean, the whole system: no mouse, no keyboard,
>>> even ssh from a different computer does not work. And sound loops
>>> endlessly.
>> This is very unlikely a PulseAudio problem. Which kernel are you
>> using? Do you see any Oopses in the logs after rebooting? Did you
>> stress-test your system under different circumstances? I would also
>> suggest you to test audio without PulseAudio, just ALSA natively, just
>> to rule out some factors.
>> Daniel
>> _______________________________________________
>> pulseaudio-discuss mailing list
>> pulseaudio-discuss at lists.freedesktop.org
>> http://lists.freedesktop.org/mailman/listinfo/pulseaudio-discuss
> _______________________________________________
> pulseaudio-discuss mailing list
> pulseaudio-discuss at lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/pulseaudio-discuss

More information about the pulseaudio-discuss mailing list