[pulseaudio-discuss] No source (typo, should be sound) from pulseaudio.. alsa is working fine though..

Colin Guthrie gmane at colin.guthr.ie
Thu Feb 2 04:50:46 PST 2012

'Twas brillig, and Shawn Ferris at 31/01/12 05:09 did gyre and gimble:
> On Mon, Jan 30, 2012 at 10:05 AM, Shawn Ferris <shawn.ferris at gmail.com> wrote:
>> On Mon, Jan 30, 2012 at 7:36 AM, Colin Guthrie <gmane at colin.guthr.ie> wrote:
>>> Hi Shawn,
>>> In the first case, is the sound going via PA or straight to dmix or
>>> similar? Typical configurations of PA will set the 'default' alsa device
>>> to the PulseAudio plugin for ALSA.
> Ok.. now that I'm home, I don't have an /etc/asound.conf nor an
> ~/.asoundrc, so unless it's getting set someplace I don't know about,
> I believe I'm routing through alsa with aplay.
>>> When you run that command (and it's "playing"), can you paste the output
>>> of "pacmd ls"? This might offer some clues.
> I grabbed a 30 sec wav file this time, verified that I could still
> hear it through aplay directly, and the captured the "pacmd ls" while
> it was playing using this command:
> paplay --device='alsa_output.platform-soc-audio.default-mapping-output'
> --volume=65537 record.wav
> And here's the output:
> http://pastebin.com/diLJiquq

For future reference, better to attach this output to the mail as
pastebins expire...) We don't mind these kind of attachments on the list
(provided you don't attach twenty of them to one mail :D)

OK, cool. Just to clarify an earlier point, near the bottom of this
output (line 546) you will see:

1 sink input(s) available.
    index: 0
        driver: <protocol-native.c>
        state: RUNNING
        sink: 1 <alsa_output.platform-soc-audio.default-mapping-output>
        volume: 0: 100% 1: 100%
                0: 0.00 dB 1: 0.00 dB
                balance 0.00
        muted: no

This is the "stream volume + mute" I mentioned earlier... so you can
mute one stream but not another (i.e. mute one application) rather than
the whole device.

In this case the volume is 0dB and it's not muted so it shouldn't be the
source of the problem.

> This is pa with the ucm patches.. I need to reset my environment, but
> I plan to try again with vanilla pa too. (it will just take a few
> hours to recompile everything)
>>> Perhaps try using a fixed resampler in your daemon.conf file to test if
>>> it's a float vs. fixed problem?
> I tried speex-fixed-3 to no avail:
> Nor did 'trivial' have any affect.

Ahh well.

>>> So this is the sink volume + mute status, what about the stream itself?
>>> It can also have a volume + mute too, so worth checking there as well.
>> I'm not sure I understand this.. I mean, I understand what you're
>> talking about, I'm just not sure I know how to look at this. Is there
>> an example that you can give me?
> Like I mentioned earlier.. I'm going to reset my environment back to a
> clean slate. I've made many changes trying to debug this, so I wanna
> make sure I haven't made things worse doing so. It's the same story
> from a completely refresh build, but I wanna for sure go back to a
> vanilla pa for now. I'll re-test once it's put back together.

I think the UCM stuff is likely doing stuff you don't actually want.

Another trick is to compare the amixer -cN output (where N is the card
in question when playing via aplay vs. paplay.

Also, you are using the sink
"alsa_output.platform-soc-audio.default-mapping-output", have you also
tried the sink "alsa_output.platform-soc-audio.1.analog-stereo"?

The alsa_output.platform-soc-audio.default-mapping-output makes me a
little suspicious as it mentions in it's alsa.id property: "Multimedia
null-codec-dai-0"... null-codec? Is that correct?

I know others have had success with panda boards (I think Arun...?) so
it should be possible.

All the best



Colin Guthrie

Day Job:
  Tribalogic Limited http://www.tribalogic.net/
Open Source:
  Mageia Contributor http://www.mageia.org/
  PulseAudio Hacker http://www.pulseaudio.org/
  Trac Hacker http://trac.edgewall.org/

More information about the pulseaudio-discuss mailing list