[pulseaudio-discuss] Issues with pulseaudio and gdm

Neil Bird gnome at fnxweb.com
Fri Jun 8 15:39:11 PDT 2012

   I've posted this in the Fedora list and googled around without 
success, so this is my next stop.

   Long story short, I have Fedora 16, upgraded from F14 (and earlier), 
but pulseaudio is not running (or dying) for the gdm+gnome-shell 
session, although it *really* wants it.  All normal users are fine.

   The side effect is that, some while after logging in, or possibly as 
I switch users, I get an entry in /var/log/messages every few seconds 
about a pulseaudio authorisation error.  I believe I have tracked these 
down to gdm's gnome-shell & gnome-settings-daemon trying to talk to *my* 
login's pulseaudio (as it's the first login and is sitting on the 
default port?).

   Unlike my freshly-installed laptop, and the VM I created to test it, 
I don't seem to have one run from start-up, although it might be 
stopping before or as I log in.

   I've tried running pulseaudio manually as gdm, but it seems to just 
exit by its own volition.  I'm running strace again on a daemon I've run 
up now.  I tried earlier today from my laptop but couldn't see anything 
but a seeming deliberate clean exit.  It doesn't automatically respawn 
like I'd expect.

   I've even copied the X11-start-pulseaudio .desktop file into gdm's 
autostart directory, and this seems to (usually) work from power up (I 
actually get an audio icon in gdm's gnome-shell's panel that makes a 
sound) but it goes when gdm's pulseaudio does, which I *think* is when I 
first log in.

   Has anyone got any ideas as to where I should start looking at this? 
  What's *supposed* to start pulseaudio?  I replaced pulseaudio in my 
test VM with a script that would do a ps and then run the real 
pulseaudio, and that indicates that it's gnome-settings-daemon that's 
spawning the pa exe, but I can't find anything explicit in the gsd source.

   I'm running the rtkit daemon, I have gdm in the pulse-rt and 
pulse-access groups (along with all local users), and I *don't* have 
anyone in the audio group (which I think causes lock problems).

   I am having random rhythmbox lock-up issues which may or may not be 
related, and I *used* to have a problem with gdm locking pulseaudio out 
(such the my user account could often not access sound), so I tried a 
couple of fixes at the time to stop gdm trying to make sounds.  I 
*think* I've undone these, but may have something stray hanging about. 
I can't see anything in files, gconf or dconf, though.

   All ideas gratefully received, this is driving me potty!

[phoenix at fnx ~]# rm -f .signature
[phoenix at fnx ~]# ls -l .signature
ls: .signature: No such file or directory
[phoenix at fnx ~]# exit

More information about the pulseaudio-discuss mailing list