[pulseaudio-discuss] Pulseaudio problem with alsa-sink

D K dspgro at gmail.com
Fri Jan 24 11:53:05 PST 2014

      I am running pulseaudio but somehow its not able to enumerate a sink.
Here PA is running as part of emulator , though it runs on the actual
system perfectly.

when i run paplay
paplay Side_Right.wav
sndfile: Bad parameter passed to function sf_command.
Failed to determine sample specification from file.

aplay Side_Right.wav
aplay: main:696: audio open error: Device or resource busy

pacmd is not working with i run pulseaudio --system mode.

when i restart PA i get this error

E: [pulseaudio] main.c: Sink pcm_output does not exist.

and when i try to connect to this sink

Somehow this command give me error saying
load-module module-alsa-sink device=hw:0,0 mmap=0 sink_name=pcm_output
fragment_size=4096 tsched=0

W: [pulseaudio] pid.c: Stale PID file, overwriting.
E: [pulseaudio] module.c: Failed to load module "module-alsa-sink"
(argument: "device=hw:0,0 mmap=0 sink_name=pcm_output fragment_size=4096
tsched=0"): initialization failed.
E: [pulseaudio] main.c: Module load failed.
E: [pulseaudio] main.c: Failed to initialize daemon.

Let me know your thoughts on this.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/pulseaudio-discuss/attachments/20140124/a67f17eb/attachment.html>

More information about the pulseaudio-discuss mailing list