[pulseaudio-discuss] IEC958 on USB Sound Blaster issue

Richard Körber pulseaudio at ml.shredzone.de
Wed Jan 29 05:23:55 PST 2014


I think just found an issue with PulseAudio. I'd like to discuss it here 
before I open a bug, because I'm not sure if it is really an issue.

My goal is to connect my notebook to a 5.1 surround amplifier via SPDIF. 
For that purpose I have bought a Creative USB Sound Blaster X-Fi HD. It 
was a good choice for the features I need.

The X-Fi HD works almost plug-and-play. When I connected it via USB, it 
was immediately detected by PulseAudio. Even the volume knob worked out 
of the box. My amplifier also detected a signal on the SPDIF line, and I 
selected the IEC958 port in pavucontrol. However, I could not play 
anything. The sound was just muted regardless of all the pavucontrol 
settings I tried.

I searched the web and found other people having the same issue, and 
also one solution. It seems that the SPDIF output is a different 
hardware device. [1]

In the /etc/pulse/system.pa I added this line:

   load-module module-alsa-sink device=hw:0,1

After a restart, I was finally able to hear sound!

However, the SPDIF output is now shown as a separate Output Device in 
pavucontrol. It also does not offer the "Advanced" options for setting 
AC3 and DTS. (According to the ALSA vendor matrix, the X-Fi HD SPDIF 
output supports AC3 and DTS.)

The IEC958 port of the original X-Fi HD device is still shown and still 

Now I wonder... Shouldn't PulseAudio detect and map the hw:0,1 device to 
the IEC958 port, so the system.pa tweak is not necessary?

If you need any command or log outputs, please let me know...

I don't have much experience with PulseAudio and ALSA, though. I'm using 
Fedora 20.

Thanks for your help!

[1] http://permalink.gmane.org/gmane.linux.alsa.user/36028

Richard Körber

More information about the pulseaudio-discuss mailing list