[pulseaudio-discuss] Cracky sound on some applications (underrun occurred)

Alexander E. Patrakov patrakov at gmail.com
Wed Feb 11 08:44:25 PST 2015

11.02.2015 21:35, Ivan Ivanov wrote:
> I have had the same problem, I can help with more data if it is needed.
>> If this helps I'm on debian jessie (testing) x86_64.
> I run the exact same OS.
> What device do you use?
> The only time this occurs in my case is when my USB headset is the output, it
> doesn't happen when I use the on-board audio. I tried some solutions that are
> proposed on the internet, but none worked. If it is needed I can provide
> conf files and logs as well.
> Everything works well if I use pasuspender, so I'd guess it is a pulseaudio
> problem.

If that's USB audio and wine, then it is 
https://bugs.freedesktop.org/show_bug.cgi?id=66962 (wrongly marked as 
fixed, because the ALSA plugin still lies to the application in the case 
when PulseAudio cannot satisfy the requested latency).

A workaround is to change, in /etc/pulse/daemon.conf, two parameters:

default-fragments = 4
default-fragment-size-msec = 5

Alexander E. Patrakov

More information about the pulseaudio-discuss mailing list