[pulseaudio-discuss] [PATCH 4/8] device-port: Add preferred_profile field to pa_device_port

Tanu Kaskinen tanuk at iki.fi
Mon Oct 19 20:03:30 PDT 2015


On Tue, 2015-05-05 at 17:01 +0200, David Henningsson wrote:
> Signed-off-by: David Henningsson <david.henningsson at canonical.com>
> ---
>  src/pulsecore/device-port.c | 1 +
>  src/pulsecore/device-port.h | 1 +
>  2 files changed, 2 insertions(+)
> 
> diff --git a/src/pulsecore/device-port.c b/src/pulsecore/device-port.c
> index cfe2a80..38f7354 100644
> --- a/src/pulsecore/device-port.c
> +++ b/src/pulsecore/device-port.c
> @@ -98,6 +98,7 @@ static void device_port_free(pa_object *o) {
>      if (p->profiles)
>          pa_hashmap_free(p->profiles);
>  
> +    pa_xfree(p->preferred_profile);
>      pa_xfree(p->name);
>      pa_xfree(p->description);
>      pa_xfree(p);
> diff --git a/src/pulsecore/device-port.h b/src/pulsecore/device-port.h
> index f35d07c..ec45a54 100644
> --- a/src/pulsecore/device-port.h
> +++ b/src/pulsecore/device-port.h
> @@ -43,6 +43,7 @@ struct pa_device_port {
>  
>      char *name;
>      char *description;
> +    char *preferred_profile;
>  
>      unsigned priority;
>      pa_available_t available;         /* PA_AVAILABLE_UNKNOWN, PA_AVAILABLE_NO or PA_AVAILABLE_YES */

It's not actually a profile that the port prefers. When the user
changes from stereo to surround, the analog-output-speakers port
doesn't care which profile gets restored, as long as the profile
contains a surround sink. Therefore, the field should be named
preferred_sink.

-- 
Tanu


More information about the pulseaudio-discuss mailing list