[pulseaudio-discuss] [Support] epic fail on espeak research (fwd)

Jude DaShiell jdashiel at panix.com
Wed Jun 29 15:07:34 UTC 2016


---------- Forwarded message ----------
Date: Tue, 28 Jun 2016 22:45:52
From: Mark Peveto via Support <support at sonargnulinux.com>
Reply-To: Mark Peveto <southernprince73 at gmail.com>
To: Sonar support <support at sonargnulinux.com>
Subject: [Support] epic fail on espeak research

Well, i had to try it.

I went ahead and installed espeakup-git, and espeak-ng-git, hoping to perhaps 
solve our problem for us, but instead I ran into these.

[southernprince at purrwurr1 ~]$ sudo espeakup

[southernprince at purrwurr1 ~]$ Assertion 'p' failed at pulse/simple.c:273, 
function pa_simple_write(). Aborting.

As you can see from above, I executed sudo espeakup, and got no errors.  But 
when I switched over to a console and logged in, when espeakup should've 
spoken, O got those errors.  Next, I went back to my terminal, and tried to at 
least get espeak-ng-git itself to talk to me.  It did, and witn no errors.

sudo espeak




Again, it echoed back hi, and returned no errors, or they'd have been printed 
out.  Next, I switched over to my etc/pulse directory, and edited default.pa, 
which my output shows.  What you don't get to see is my change to default.pa. 
I went down the file, until I found load-module load-module-udev-detect, and 
added tshed=0 to the end of the line.

load-module load-module-udev-detect tsched=0

Then saved the file.

[southernprince at purrwurr1 ~]$ cd /etc/pulse

[southernprince at purrwurr1 pulse]$ sudo nano default.pa

[southernprince at purrwurr1 pulse]$ cd

[southernprince at purrwurr1 ~]$ sudo pkill pulseaudio

[southernprince at purrwurr1 ~]$

[southernprince at purrwurr1 ~]$ sudo espeakup

I killed pulseaudio so it'd restart with my new settings, then executed 
espeakup again.  Switching to a console again, I got errors, but after changing 
the line in default.pa, the errirs changed slightly.

[southernprince at purrwurr1 ~]$ ALSA lib pcm_dmix.c:1029:(snd_pcm_dmix_open) 
unable to open slave

error: Device or resource busy

espeakup: pcm.c:1122: snd_pcm_drain: Assertion `pcm' failed.

[southernprince at purrwurr1 ~]$

I'll get up in the mornin, and remove these, putting back regular espeak.  I'll 
leave espeakup-git, since it was working fine.  Espeakup-ng-git breaks things, 
too.  But hey, figured I'd try.
Mark Peveto
Registered linux user number 600552
Sent from Sonar!
-------------- next part --------------
Support mailing list
Support at sonargnulinux.com

More information about the pulseaudio-discuss mailing list