[pulseaudio-discuss] PA 9.0, Failed to create secure directory

Tanu Kaskinen tanuk at iki.fi
Tue Oct 4 10:44:44 UTC 2016

On Tue, 2016-09-27 at 14:59 -0400, Jason Gauthier wrote:
> I just installed PA from source on Debian Jessie.  I've done this
> several times on other systems. But for some reason, when starting PA,
> I am getting this error:
> E: [pulseaudio] core-util.c: Failed to create secure directory
> (/opt/pulseaudio/var/lib/pulse): Permission denied
> I am running as root, with --system, which for some reason seems to be related.

When pulseaudio starts in the system mode, it will switch to the pulse
user. /opt/pulseaudio/var/lib is probably owned by root, so the daemon
doesn't have the necessary permissions for creating its state

If you create /opt/pulseaudio/var/lib/pulse manually and chown it to
pulse:pulse, it might work.

I don't know how distributions handle this. At least on my machine
/var/lib/pulse doesn't exist, so pulseaudio has to create it if run in
the system mode, which should result in the same error, but then I'd
expect this to be a common issue, but I don't remember anyone
complaining about this before.

I can verify that I get the same error when I try to run pulseaudio in
the system mode when installed in /usr/local. I can't test this right
now with the distro version of pulseaudio, however, because if I try,
the libraries installed in /usr/local cause conflict and the daemon
fails before it even starts.


More information about the pulseaudio-discuss mailing list