[pulseaudio-discuss] running pulseaudio on an embedded device with no X as a network sink

Doron Behar doron.behar at gmail.com
Thu Dec 28 09:34:29 UTC 2017

Hello everyone,

I'm trying for a while now to run pulseaudio on my Raspberry-Pi 3 and
I can't get it to work. I posted a question with a lot of details on


As I said there, I have installed `omxplayer`. It works, proving my
hardware is totally OK.

I want to eventually plug my Raspberry-Pi into electricity and to be able
to add a network sink from a different computer with a command like this
running on the local machine:

pacmd load-module module-tunnel-sink server=archpi

I'm pretty sure that eventually the way to do this involves having an
enabled systemd service that will run `pulseaudio --daemonize=false

Here is what I've tried so far:

I've tried to test this with `sudo pulseaudio --system=true -vv
--daemonize=false` on a user session.

I also made sure the file `/etc/pulse/system.pa` on the remote machine has
the following lines:

load-module module-native-protocol-tcp auth-ip-acl=; auth-anonymous=true
load-module module-zeroconf-publish
load-module module-zeroconf-discover

I'm not totally sure whether the arguments given in the first line are
good for my purpose so I'll be happy to get some feedback here about it as

Plus, I'm not totally sure about whether I'm supposed to be able to do it
using ssh or perhaps it is possible only on a tty when testing it.

I've tried to test it with ssh, tty and with an attached tmux session
which was invoked from tty. I haven't successfully could actually hear
sounds when I tried to play audio files with neither of these options.

I'm not totally sure how am I supposed to test this. I tried
`aplay` and `pacmd play-file` and none of them worked, I tried running
these commands using as before using a separate ssh session, an attached
tmux session and a pure tty session and no success.

I also tried to do what is suggested on this post from unix.stackexchange:

I'm not sure whether I should do it locally or with an attached tmux
session and testing it in a different tmux windows using `aplay` or
whether I could do it in an ssh session. I couldn't hear any sound in each
one of those environments. I tried both `aplay -D pulse` and both `aplay
-D plughw:0,1`.

I could really use some help here since I'm getting very frustrated.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 659 bytes
Desc: not available
URL: <https://lists.freedesktop.org/archives/pulseaudio-discuss/attachments/20171228/740bf371/attachment.sig>

More information about the pulseaudio-discuss mailing list