[pulseaudio-discuss] Unable to run pulseaudio on embedded platform

Tanu Kaskinen tanuk at iki.fi
Wed Feb 8 12:25:54 UTC 2017

On Thu, 2017-02-02 at 17:29 +0530, Rinaldo Rex wrote:
> Hi,
> I'm working on an embedded platform which runs automotive grade Linux. I'm
> trying to use pulseaudio for a while now and it keeps failing. I've tried
> modifying the configuration files and also by removing them to regenerate
> the default values. Neither worked in an usable setup.
> Please find the attached file as to what I've tried doing so far and please
> guide me in proper direction.

Ok, I'll quote the attachment here:

> root at salvator-x:~# pulseaudio -vvvv --system
> W: [pulseaudio] main.c: Running in system mode, but --disallow-exit not set!
> W: [pulseaudio] main.c: Running in system mode, but --disallow-module-loading not set!
> N: [pulseaudio] main.c: Running in system mode, forcibly disabling SHM mode!
> E: [pulseaudio] main.c: Daemon startup failed.
> root at salvator-x:~#

The "Daemon startup failed" message is only printed when trying to
launch pulseaudio as a background process. You didn't pass --daemonize
on the command line, so pulseaudio shouldn't try to start a background
process. Did you put "daemonize = true" to daemon.conf? You said that
you had no changes in daemon.conf, and if that's true, then the only
explanation I can think of is that your version of pulseaudio has been
modified to daemonize by default.



More information about the pulseaudio-discuss mailing list