[pulseaudio-discuss] Sound input problem on chtrt5645 device

Hans de Goede hdegoede at redhat.com
Sun Jul 1 14:18:44 UTC 2018


On 29-06-18 18:25, Gustavo Duarte wrote:
> Hi Hans,
>> I assume that when you say there is no input sound, you mean that the
>> microphone build into the laptop is not working ?
> That's right.
> I tried your suggestions, substitute HiFi.conf file and add these
> kernel command line parameters. And the mic, still desn't works.
> I tried also dmic on 1st and 2nd input.
> There is something that catches my attention.
> Always after did a change, I go to Gnome sound settings, input tab,
> and the only device showed is chtrt5645 Analog Stereo.
> I expected see a digital device... i don't know.

If you see "chtrt5645 Analog Stereo" on the input tab, then the
UCM profile is not loading correctly. You need to fix that first,
if you have an old alsa-lib which did not include a
/usr/share/alsa/ucm/chtrt5645 yet, then start with copying
both HiFi.conf and chtrt5645.conf from:


To a directory named:


Note you need the plain txt (raw) versions of both files.
Then close the gnome sound-settings, do "killall pulseaudio"
and re-open gnome-sound-settings.

The input should be named "Internal Analog Microphone" now,
once you've managed to get the input named that way (so the UCM
profile is loaded correctly) try if the buildin mic works now.

If things still don't work, then replace the HiFi.conf with
the file from the Asus T100HA profile I linked to before *and*
put snd_soc_rt5645.quirk=0x0100 on the kernel commandline.

Note to test the digital-mic you need both the Asus T100HA
HiFi.conf *and* the kernel commandline option.

To check the kernel commandline option is present after
rebooting do: "cat /proc/cmdline", if you are using the
Asus T100HA HiFi.conf, the input should now be named
"Internal Microphone" (note no more "Analog" in there).



> On Fri, Jun 29, 2018 at 11:00 AM Hans de Goede <hdegoede at redhat.com> wrote:
>> Hi,
>> On 28-06-18 12:59, Tanu Kaskinen wrote:
>>> On Wed, 2018-06-27 at 10:10 -0300, Gustavo Duarte wrote:
>>>> On Fri, 2018-06-15 at 12:56 -0300, Gustavo Duarte wrote:
>>>>> * Hi all,
>>>> *> >* The input sound isn't working. No sound is detected.
>>>> *> >* Environment:
>>>> *> >* Laptop brand: JP Couto model EF20EA
>>>> *> >* Distributor ID: Ubuntu
>>>> *>* Description: Ubuntu 16.04.4 LTS
>>>> *>* Release: 16.04
>>>> *>* Codename: xenial
>>>> *> >* Linux Kernel: 4.15.0-23-generic
>>>> *> >* Right after install Ubuntu 16.04 on the laptop, the sound output and input
>>>> *>* isn't worked.
>>>> *> >* So i followed this procedure:
>>>> *>* https://ubuntuforums.org/showthread.php?t=2374383&p=13698722#post13698722
>>>> <https://ubuntuforums.org/showthread.php?t=2374383&p=13698722#post13698722>
>>>> *>* and then, output sound starting to work, but input not.
>>>> *> >* An strange thing is that output of amixer -cO is empty.
>>>> *
>>>> On your machine card 0 is HDMI, which is why amixer -c0 is empty.
>>>> amixer -c1 will show the chtrt5645 mixer settings.
>>>> There have been input related fixes to chtrt5645's UCM config recently.
>>>> This is the latest
>>>> version:http://git.alsa-project.org/?p=alsa-lib.git;a=blob_plain;f=src/conf/ucm/chtrt5645/HiFi.conf;hb=HEAD
>>>> Try copying that to /usr/share/alsa/ucm/chtrt5645/HiFi.conf
>>>> --
>>>> Tanu
>>>> I tried this fix, after substitute HiFI.conf file and reboot the laptop,
>>>> sound configuration options changed, output sound still working, but input
>>>> NOT.
>>>> Something else to do ?
>>>> Thanks.
>>> Apparently your laptop requires some special configuration for the mic
>>> to work. There are a couple of different rt5645 UCM configurations
>>> already in alsa-lib:
>>> http://git.alsa-project.org/?p=alsa-lib.git;a=tree;f=src/conf/ucm;hb=HEAD
>>> You can try playing with "alsamixer -c1" to find out what settings need
>>> to be changed. If you manage to find a working settings, then the UCM
>>> configuration can be fixed.
>>> I'll add Hans de Goede to Cc in case he has any hints or is otherwise
>>> interested (he has fixed input for some other laptops that use rt5645).
>> I assume that when you say there is no input sound, you mean that the
>> microphone build into the laptop is not working ?
>> It could be that your laptop is using a digital mic rather then an analog one.
>> To try for a digital mic on the 1st dmic input, copy:
>> git.alsa-project.org/?p=alsa-lib.git;a=blob_plain;f=src/conf/ucm/ASUSTeKCOMPUTERINC.-T100HAN-1.0-T100HAN/HiFi.conf
>> To /usr/share/alsa/ucm/chtrt5645/HiFi.conf
>> *AND* put snd_soc_rt5645.quirk=0x0100 on the kernel commandline.
>> If that does not work you can also try:
>> snd_soc_rt5645.quirk=0x0200
>> snd_soc_rt5645.quirk=0x0300
>> snd_soc_rt5645.quirk=0x0400
>> There also is a second digital mic input, but there is no matching UCM file
>> for that, so you would need to edit the ucm HiFi.conf file yourself, or
>> play with alsamixer -c 1. To try and activate a dmic on the 2nd input try:
>> snd_soc_rt5645.quirk=0x1000
>> snd_soc_rt5645.quirk=0x2000
>> snd_soc_rt5645.quirk=0x3000
>> Regards,
>> Hans
>> _______________________________________________
>> pulseaudio-discuss mailing list
>> pulseaudio-discuss at lists.freedesktop.org
>> https://lists.freedesktop.org/mailman/listinfo/pulseaudio-discuss

More information about the pulseaudio-discuss mailing list