[pulseaudio-discuss] [PATCH] Add configurable RTP stream name

Tanu Kaskinen tanuk at iki.fi
Wed Jul 4 10:27:34 UTC 2018


On Wed, 2018-07-04 at 11:10 +0200, Ing. Jaroslav Šafka wrote:
> On středa 4. července 2018 11:00:08 CEST Tanu Kaskinen wrote:
> > On Thu, 2018-06-28 at 22:16 +0200, Ing. Jaroslav Safka wrote:
> > > Path add configuration option 'stream_name' for stream/session name
> > > So user will see it on receiver side as RTP Strean ($stream_name)
> > > 
> > > ex: load-module module-rtp-send source=rtp.monitor 
> 
> stream_name=MyServerMedia
> > > ---
> > >  src/modules/rtp/module-rtp-send.c | 17 +++++++++++++----
> > >  1 file changed, 13 insertions(+), 4 deletions(-)
> > > 
> > > diff --git a/src/modules/rtp/module-rtp-send.c b/src/modules/rtp/module-
> 
> rtp-send.c
> > > index 61900c01..a65f1ba3 100644
> > > --- a/src/modules/rtp/module-rtp-send.c
> > > +++ b/src/modules/rtp/module-rtp-send.c
> > > @@ -66,6 +66,7 @@ PA_MODULE_USAGE(
> > >          "loop=<loopback to local host?> "
> > >          "ttl=<ttl value> "
> > >          "inhibit_auto_suspend=<always|never|
> 
> only_with_non_monitor_sources>"
> > > +        "stream_name=<name of the stream>"
> > >  );
> > > 
> > >  #define DEFAULT_PORT 46000
> > > @@ -90,6 +91,7 @@ static const char* const valid_modargs[] = {
> > >      "loop",
> > >      "ttl",
> > >      "inhibit_auto_suspend",
> > > +    "stream_name",
> > >      NULL
> > >  };
> > > 
> > > @@ -229,6 +231,7 @@ int pa__init(pa_module*m) {
> > >      bool loop = false;
> > >      enum inhibit_auto_suspend inhibit_auto_suspend = 
> 
> INHIBIT_AUTO_SUSPEND_ONLY_WITH_NON_MONITOR_SOURCES;
> > >      const char *inhibit_auto_suspend_str;
> > > +    const char *stream_name = NULL;
> > >      pa_source_output_new_data data;
> > > 
> > >      pa_assert(m);
> > > @@ -261,6 +264,8 @@ int pa__init(pa_module*m) {
> > >          }
> > >      }
> > > 
> > > +    stream_name = pa_modargs_get_value(ma, "stream_name", NULL);
> > 
> > If you replace this with
> > 
> >     n = pa_xstrdup(pa_modargs_get_value(ma, "stream_name", NULL);
> > 
> > then you don't need a new stream_name variable.
> > 
> 
>  
> yeah, question is if make additional allocation or have additional variable.
> What owners prefer? :)

I prefer the additional allocation.

-- 
Tanu

https://liberapay.com/tanuk
https://www.patreon.com/tanuk


More information about the pulseaudio-discuss mailing list