[pulseaudio-discuss] Sound input problem on chtrt5645 device

Gustavo Duarte gus.duarte at gmail.com
Wed Jun 27 13:10:22 UTC 2018

On Fri, 2018-06-15 at 12:56 -0300, Gustavo Duarte wrote:
>* Hi all,
*> >* The input sound isn't working. No sound is detected.
*> >* Environment:
*> >* Laptop brand: JP Couto model EF20EA
*> >* Distributor ID: Ubuntu
*>* Description: Ubuntu 16.04.4 LTS
*>* Release: 16.04
*>* Codename: xenial
*> >* Linux Kernel: 4.15.0-23-generic
*> >* Right after install Ubuntu 16.04 on the laptop, the sound output and input
*>* isn't worked.
*> >* So i followed this procedure:
*>* https://ubuntuforums.org/showthread.php?t=2374383&p=13698722#post13698722
*>* and then, output sound starting to work, but input not.
*> >* An strange thing is that output of amixer -cO is empty.
On your machine card 0 is HDMI, which is why amixer -c0 is empty.
amixer -c1 will show the chtrt5645 mixer settings.

There have been input related fixes to chtrt5645's UCM config recently.
This is the latest

Try copying that to /usr/share/alsa/ucm/chtrt5645/HiFi.conf


I tried this fix, after substitute HiFI.conf file and reboot the laptop,
sound configuration options changed, output sound still working, but input

Something else to do ?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.freedesktop.org/archives/pulseaudio-discuss/attachments/20180627/731414ff/attachment.html>

More information about the pulseaudio-discuss mailing list