[pulseaudio-discuss] Sound input problem on chtrt5645 device

Hans de Goede hdegoede at redhat.com
Fri Jun 29 13:02:40 UTC 2018


On 28-06-18 12:59, Tanu Kaskinen wrote:
> On Wed, 2018-06-27 at 10:10 -0300, Gustavo Duarte wrote:
>> On Fri, 2018-06-15 at 12:56 -0300, Gustavo Duarte wrote:
>>> * Hi all,
>> *> >* The input sound isn't working. No sound is detected.
>> *> >* Environment:
>> *> >* Laptop brand: JP Couto model EF20EA
>> *> >* Distributor ID: Ubuntu
>> *>* Description: Ubuntu 16.04.4 LTS
>> *>* Release: 16.04
>> *>* Codename: xenial
>> *> >* Linux Kernel: 4.15.0-23-generic
>> *> >* Right after install Ubuntu 16.04 on the laptop, the sound output and input
>> *>* isn't worked.
>> *> >* So i followed this procedure:
>> *>* https://ubuntuforums.org/showthread.php?t=2374383&p=13698722#post13698722
>> <https://ubuntuforums.org/showthread.php?t=2374383&p=13698722#post13698722>
>> *>* and then, output sound starting to work, but input not.
>> *> >* An strange thing is that output of amixer -cO is empty.
>> *
>> On your machine card 0 is HDMI, which is why amixer -c0 is empty.
>> amixer -c1 will show the chtrt5645 mixer settings.
>> There have been input related fixes to chtrt5645's UCM config recently.
>> This is the latest
>> version:http://git.alsa-project.org/?p=alsa-lib.git;a=blob_plain;f=src/conf/ucm/chtrt5645/HiFi.conf;hb=HEAD
>> Try copying that to /usr/share/alsa/ucm/chtrt5645/HiFi.conf
>> -- 
>> Tanu
>> I tried this fix, after substitute HiFI.conf file and reboot the laptop,
>> sound configuration options changed, output sound still working, but input
>> NOT.
>> Something else to do ?
>> Thanks.
> Apparently your laptop requires some special configuration for the mic
> to work. There are a couple of different rt5645 UCM configurations
> already in alsa-lib:
> http://git.alsa-project.org/?p=alsa-lib.git;a=tree;f=src/conf/ucm;hb=HEAD
> You can try playing with "alsamixer -c1" to find out what settings need
> to be changed. If you manage to find a working settings, then the UCM
> configuration can be fixed.
> I'll add Hans de Goede to Cc in case he has any hints or is otherwise
> interested (he has fixed input for some other laptops that use rt5645).

I assume that when you say there is no input sound, you mean that the
microphone build into the laptop is not working ?

It could be that your laptop is using a digital mic rather then an analog one.

To try for a digital mic on the 1st dmic input, copy:


To /usr/share/alsa/ucm/chtrt5645/HiFi.conf

*AND* put snd_soc_rt5645.quirk=0x0100 on the kernel commandline.

If that does not work you can also try:


There also is a second digital mic input, but there is no matching UCM file
for that, so you would need to edit the ucm HiFi.conf file yourself, or
play with alsamixer -c 1. To try and activate a dmic on the 2nd input try:




More information about the pulseaudio-discuss mailing list