[pulseaudio-discuss] Problem: non-interactive pulseaudio ( headless )

Brian Bulkowski brian at bulkowski.org
Mon Aug 26 14:31:47 UTC 2019


Heaving read how bad headless is, and how it's "rarely" needed and may 
not work, I was a bit blase about running my interactive art 
installation from systemd.

After all, systemd allows me to run as a user.

When I run as a non-interactive user, I get a "pulseaudio can't 
connect", which is an errno 6.  This happens from systemd, after 
everything's started, I'm just debugging so I'm running my systemctl 
start mylousy.service....

 From what I read here, the aversion to running as a service is 
security, and if I run as a user everything should be fine, but it is 
the connect call that failing.

Regrettably I'm at a place with limited connectivity, but any tips would 
be welcome, or at least for the next person who is trying to run a 
perfectly reasonable headless installation.

Thanks & Regards,


More information about the pulseaudio-discuss mailing list